Inter connectivity problems btw Naim and TIDAL?

Dear fellow Naim owners,

I’ve just purchased a NAIM Mu-so 2nd gen, which I am very, very pleased with. Beautiful piece of HiFi.

I am, however, having problems with the Naim app and TIDAL. I logged on TIDAL on the NAIM app but when I press to play a track, it does not play and after five seconds the display goes from the title of the track to saying ‘ready’ and nothing more happens. Very strange. TIDAL works nicely on my Mu-so when I play from the TIDAL app via Airplay. Even when music is playing that way directly from the TIDAL app, I can switch to the NAIM app and it looks normal like the integrated TIDAL is working. I can even click forward to the next song from NAIM app and it plays. But when I try to choose something differently, it fails to play again and just says ‘ready’. Very odd.

Any of you come across this particular problem? All apps and firmware are updated.

Hope you can help!


Anyone else in the family ‘sharing’ your Tidal login? You can get this type of issue if the Tidal account is being used elsewhere on a different machine.

Or it could be something entirely different!

This is happening regularly to me on an ndx2 with Naim app on an iPad Pro.

It’s becoming almost unusable now…not impressed. I have logged out of tidal on the Naim app and rebooted the iPad and the ndx2

Forgot to say that there is no sharing of Tidal going on

And also forgot to say that there are no queuing and playback issues with Spotify when using the Naim app. Why can Naim not sort out these issues with Tidal…or accelerate the release of the Qobuz api?

Hi Gavin. No sharing. I have Tidal app on both my phone and IPad, but I don’t assume that should cause any problems?

Hi Hasselblad100! Seems like we share the problem! I’ve been experimenting with all kinds of attempts to fix it but still no luck. Sooo frustrating! I wrote Naim about it too. No reply yet.

Are you paying for the ‘hifi quality’ version of Tidal? If not then you need to set whatever quality level that you are paying for under the Input settings for Tidal. By default this is set to Hifi, so anything less than won’t play.

Hi. I am having issues with connectivity too. Not sure if it’s exactly the same but it still sucks.
I’m running the latest Tidal App & Naim App on my iPhone X with latest iOS software 13.1.2

Since (9/10) I am currently unable to Chromecast Tidal to my Naim Atom. The Chromecast symbol flutters as it should in the app whilst trying to connect, but does not connect. But that’s it. Then it defaults back to the home screen.
If I open Tidal hit Chromecast it will switch Atom on but that’s all. No connection lock with Tidal.

I have factory reset everything including the Atom (many times) my home WiFi router, and re installed all apps. Tried using WiFi & Ethernet connection to the Atom.

I can play my Tidal tracks via the Naim App however no problem.

Qobuz works fine with Chromecast to the Atom so it must be a Tidal issue.
I’ve contacted Tidal & Naim. No response from Naim. Tidal looking into it. Ho Hum!

Hi @Terkelborg,

In regards yo your issue where Tidal won’t play via the built-in Tidal implementation, i would suggest check a few things:

  1. On the naim app while using the muso, go to. Settings(gear icon)->input settings->tidal>logout. . Then reselect the tidal input on the home screen, type in your username and password. Pick something to play and see what happens. It maybe a little slow on reacting to the first play. From what you describe it indicates the app is logged into your account, but the product is not.

  2. Check for unusual characters in the username or password. Eg. Accented characters, symbols or the like. Nowadays Tidal limit the characters that can be used, but older accounts can carry a legacy.

Please note I think there are a wealth of very different issues being described on this thread, so the advice above is strictly for your case, not for the others.

Best regards

Steve Harris
Software Director

When I first got my MuSo (first generation) I constantly had drop out and ‘stuttering’ playback issues. It transpired this was due to my network, albeit that wasn’t clear at all in use. I was relying on WiFi connection - It turned out where it was placed was in a a wifi blind spot - very confusing because other parts of the same room had super fast WiFi connection. It was only when I ran new cable and hard wired it to my router and thus to my NAS that it worked perfectly. No idea if that is helpful! Good luck.

Hi Steve! Thanks for this feedback! I tried it and also changed my password to something more straightforward. Initially I almost thought it worked - like you mentioned, it seemed that it took a little extra time for the build-in Tidal to load but eventually it went back to the same as before: seeming like it is about to play but then aborting and just displaying ready. Really strange. I check that the Naim App’s Tidal settings were in sync with the Tidal app itself (tried but HiFi, high, and normal) but this didn’t seem to have an effect either.

Is there anything else, I could try?

Thanks again for your help!


Hi @Terkelborg,

Ping me an email on steve.harris(at) and i’ll talk you through some other things to try.




Just to close the loop, @Terkelborg and I have been breaking this one down.

The problem is that he is using a vpn and Tidal purposely block access to the streams when using a VPN and using the third party integrator Tidal API. I suspect this is to stop pirates ripping off music and hiding their identity via a VPN. The Tidal app uses a different api which is more secure and is willing to stream the music.

With regards

Steve Harris
Software Director


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.