iRadio Directory Issue

Greetings all

I have a Uniti2 and am experiencing an issue using the Naim app to search for internet radio stations. I am reasonably comfortable setting up networks and would consider myself reasonably IT savvy so I am confident there’s nothing wrong with my network (famous last words). For what it’s worth Spotify Connect works, and I can access internet radio stations without issue. It’s just a specific issue with finding them that is vexing me at the moment…

In the app I can see all the options (Most popular, Naim’s Choice, Location etc.), and I have no problem selecting stations, listening to them and saving them as favourites - great. However if I choose Location/Europe/United Kingdom/All stations, the list is blank. I can see UK stations if I choose a genre (e.g. Blues) rather than selecting ‘All stations’, but it’s irritating to have to do this and it makes it harder to find a specific station. The same happens if I choose All popular - the list is empty. I know the stations are all there; the ‘Pop’ genre list is pages and pages long!

I wondered whether anyone else is having the same issue. I have a vague recollection that it things worked properly at some point in the not-too-distant past but I’d appreciate any help anyone can offer.

Very best wishes, and happy listening

I’ve just tried it on a Qb and it seems fine. You may need to wait while it populates.

My iPad + NDX is OK, a huge list.
Have you tried resetting the app, or delete & reinstall ??

Thanks both - really appreciate the speedy responses. Good to know that it works OK for others.

I’ve tried resetting the app, then deleting and reinstalling but still no joy. If I try leaving it longer to populate the circle just stops spinning after a second or so, and the list remains empty.

The population of the list on mine doesn’t take so long,
I have 74mb/s download speed, what’s yours??
What app are you using, iOS or Android?

I’m on iOS, with a wired download speed of >100MBps. The station lists load within a second when they populate by genre, it’s just the ‘All stations’ lists for each country which don’t work for me…I’m stumped.

One last thing that might do the trick is to clear out any old/bad install links that might be stuck in the system. Its something I had a while back in another app, it might be worth a try for the sake of 5 minute,
First delete the Naim app (again).
Double click on the home button, this brings up a screen with small versions of all the apps in the memory.
Swipe each of these ‘up & off’ until the screen goes back to ‘home’.
Do it again to be sure you’ve removed them all
Force power off by folding the home & on/off buttons simultaneously until the Apple logo appears, then wait for a few seconds for the home screen & then reinstall the app & fingers crossed.

Thanks Mike-B - I’ll give this a go.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.