iRadio in Naim app on Muso

It’s not causing me a problem at the moment to be fair, but I noticed that after selecting a country, the first two options in the menu are ‘All Stations’ and then ‘Selected stations’. (My phone is in Spanish so I may not have translated it exactly how it appears in English.)

Whatever country I select, when selecting ‘All Stations’ I get the whirring circle for a couple of seconds and then just a blank contents.

Is this a known bug?



I just tried it on a Muso QB here in Australia, using an iPhone 6s and the app version 5.11.2
I can select any region, Country and “All Stations” and it works just fine.
I also tried selecting “Spain” and then “All Stations” and that is also working just fine for me.
After selecting the “Country”, I have many options including; “All Stations”, “Alternative”, “Ambient”, “Big Band”, “Blues” etc. etc.

Thanks for checking it out. Hmmm…strange.

I’m using the same version of the app on an iPhone X and have firmware version 1.8.00

I have various genres listed in the menu as well. Do you have a ‘Selected stations’ option directly under the ‘All Stations’ option?

Maybe it just happens if you live in Spain. It’s only something I’ve noticed since moving here. Pretty sure it worked ok in the U.K. I’m not sure if it’s ever worked properly here in Spain or not.

Also although there is a much smaller list of stations under ‘Selected stations’ you seem to be able to access additional stations by going into the various genres. For example ‘Naim Radio’ and BBC local stations do not appear in ‘Selected stations but appear in ‘Variety’. And Linn Classical only appears under ‘Classical’. Could be a quirk in vTuner I guess.

There was a vTuner problem over the last few days, it was fixed yesterday.

I’ve had this ‘feature’ for some time and it’s still here today.

It’s not a huge issue, just a bit odd.

OK, seems like it was not related to the vTuner issue in the last few days. I just thought it was worth mentioning.

You might try an e-mail to Naim Support & they can pass it on the software dept

I don’t have a Muso BTW

Hello all together,
I am experiencing the problem as mentioned above. I have tried to contact naim support, but the response time was really bad (it took 3 weeks for an answer and a possible solution), the solution from naim was that my router has problems and that I should try to connect my muso to another router or to take it to the dealer and try with their router/network. The result was/is always the same. I can’t see all station menu, but I have noticed that this is happening only on European stations. For the rest of the world it is working flawlessly.


As it didn’t stop me listening to any of the stations I wanted to, I didn’t actually raise it with Naim support.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.