Issue on iPad Pro 2018

I have an iPad Pro 2018, which replaces the iPad Air 2. When I search « 10 » on the iPad Air 2, it finds the right site via google.
But via IPad Pro, I am directed to a pharmacy site, nothing common with 10 audio. Why?

Then another site: Positive On iPad Pro, i can’t put the site on my screen ( raccourci sur écran d’accueil). But can do that on iPad Air 2. Strange.

First thoughts are whether they are using the same network, or us one Wi-fi and the other via an ISP. In other words using different dns addresses

Or are they using different search engines. Try the same search from on each

Same network by WiFi at home. I tried both via google search and also via Safari. Same results.

Sounds like your browsers have possibly picked up a rogue script.
Uninstall and reinstall…or do a factory reset after a backup.

have you checked Settings/Safari/Search Engine setting, and perhaps compare all the settings here to your working iPad, going down to each sub level. Try using the “clear history and Website Data”. Also are you using the same Apple Id

I can replicate this in Safari on my Mac (High Sierra).

The short URL - this goes to the hi-fi site

It is indicated as non-secure. The site seems to be hosted by GoDaddy. There is no https:\ or https:\ available

The bottom of the page weblink (below in orange) accessed from the proper site also returns to the proper site.

Google search includes this top hit which looks correct:

Screen Shot 2020-12-12 at 10.49.02

but it redirects on clicking randomly to several pharmacy sites selling ‘uplifting’ products.

If you select the cached version however from Google it shows the correct site but either the hyperlink for the cached site info provided by Google or ‘orange link’ in the cached site go to a pharmacy site.


Could certain DNS servers have been compromised?

Many other possibilities.

Have you contacted the site owner?

Safari is clearly remembering certain searches, so I now see things like:

Screen Shot 2020-12-12 at 10.12.07

Screen Shot 2020-12-12 at 10.39.07

This may be related to search options for Safari.

I don’t think it’s respecting some of these options I’ve tried changing, can’t remember what options there are on iPad.

Screen Shot 2020-12-12 at 11.10.08

Not sure if private browsing might help, probably not.

Spotlight might also be a culprit on the Mac.

1 Like

Clear the cache, power off and restart.

I had a problem a few months ago that the Guardian newspaper website kept resulting in my phone being sent to a site that tried to exhort bitcoins from me “to unlock your phone”. In fact deleting that page in the browser was enough to escape. But I couldn’t read the newspaper! It only did it when I was on WiFi and hence using Virgin Media’s DNS servers and it didn’t happen if I turned off the WiFi in the phone and connected via Vodafone 4G. My iPad wasn’t affected, because it was using the desktop site rather than the mobile site.

Ultimately I solved the issue by telling my phone to use Google DNS servers instead of Virgin Media’s. And then I started using the Guardian app which is better on a phone than the mobile version of the paper anyway.

So my suggestion would be to change the DNS settings in your iPad.



1 Like

How clear the cache?

Via settings then safari

1 Like

Wild guess (or just something to check): different language settings for the OS/browser can influence search results as well.

As Gadgetman says via settings and Safari then clear history and website data.

1 Like

The issue here is that the website has been compromised by malicious scripts, sql injection maybe? It used to be a common problem with developers writing insecure scripts that were easily attacked.

Clearing the cache/power off etc won’t do anything as the problem is with insecure aplication allowing script injections on their server.

So some of its pages are being returned with links to the viagra (injected) whilst some go to the correct pages.

The site is running on an outdated version of Drupal 7.26 (should be V9) so very vulnerable to script hacks

Please contact the site owner and get them take action ASAP.


The apple dealer confirmed me that, it’s a site problem, not iPad settings.
I tried to reboot it, switch off and on, clear the cache before, tried different settings in Safari, went by google, google chrome and also Safari: still the same.

Anyone here use the IPad Pro 2018 or 2020? Can try to open “ 10 audio. com” site?

What are DNS settings? How change them?

Works for me on ipad. If there was a site problem I would think that everyone who tried to acces it would see it.

Which IPad model you have?
On my ex IPad Air 2, I could have the site. Not iPad Pro 2018.

See my previous post:

Nothing to do with DNS, but they are under network settings

@raym55 ste has been compromised via malicious scripting taking advantage of out dated software Drupal V 7.26 hopelessly out of date and vulnerable to SQL script injection.

Site owner needs to take down files from host server, update Drupal then re-install site files as attacker may have left a backdoor on the server.

Part 2 of your queery, I understand you want a bookmark on the desktop? so probably just a matter of visiting site, and tap the “+” icon to the left in the address bar.

Yes, I feel you are right. I responded you previously, when the iPad dealer responded. But I don’t understand how it can work on some iPad models and not other.