Issue out of the box Supernait3

Hi everyone

just got a brand new supernait 3 today, and out of the box, powered on, the green logo is on, but selection buttons do not respond, Remote does not respond, vol knob does not respond. no other light than the logo.

any such experience?
thank you

1 Like

Sorry to read this Jean.

Are the batteries in the remote okay?

Has the unit been switched to no display lights? (see manual)

If the answers to these questions are yes and no, then please contact your dealer in the morning.

1 Like

Is the link plug in place properly ?


I have checked the batteries, they are at 1.6v,
Do you mean the no display option using the remote and pressing the Disp key? I have tried, it does not react.

Does it make a click a little bit after switching it on? (The internal relay making the click).
I would start by pulling the power lead, giving it a good shove back in place, and try again.

No relay sound as such

Time to contact your dealer.

1 Like

With the power off, just take the link plug out and then push it back in again then power back up. If no success then as others have said, it’s back to the dealer.

Are they the right way round?

@NeilS any ideas Neil? It’s not in soak mode or similar possibly? Thanks

Is the remote in Pre mode. Press pre to get the remote in the mode ti control vol and balance

1 Like

But there should be a light on the front to show which input has been selected. Is it in power amp mode? That would match with all the front lights being off except the logo.

1 Like

With just the power connected*, switch the unit on while pressing the mute button on the front panel.
If that doesn’t bring it to life, I fear they may be a power supply rail missing/failed within.


*No speakers, but link plug fitted!


Yes just tried, no change

It should work without the remote, and it does not unfortunately for me

Yes the remote is in pre mode. Actually I first got a used SN3 so got used to it but had to return it as the av bypass was not working. Then I had a Nait xs3 from my dealer for trying, all was working very well, then order this brand new SN3 that I received today but it does not work it seems. I already informed my dealer, they need to contact someone at Naim tomorrow. In the meantime I wanted to ask you if there is anything I missed.

Remote works, it operates the volume and mute my Marrantz preamp.
But SN3 still not.
I tried to power on while pressing mute but no effect. Also tried to remove the DIN bridge, then put it back while powering on but no result.

Have you tried what Neil from Naim suggested above?

It may also be worth just borrowing a link plug from your dealer to rule out a plug issue before hauling the whole unit in.

1 Like

Hello, yes I have tried and it dis not work.
You are right, it could be the bridge plug.
My dealer has been in contact with Naim and they also mentioned a possible issue with the plug. I understood they will replace the unit, I will wait for the instructions. Thanks for your suggestions

1 Like