Issue with Tidal on NDX - Can't play ... skipped track

Hello. Issues with my NDX (2015 no bluetooth) seem to be piling up.
I have the latest firmware update (4.8) and the latest app version (6.0.1).
My Tidal HiFi Plus subscription is valid and running, and I can stream Tidal content via a bluetooth device connected to the Digital 3 port on the NDX.
When I access Tidal through the Focal & Naim App on my iPhone I can choose any track but the NDX won’t play and the “Can’t Play - skipped track” message appears on the display.
I understand this has already happened in the past when changes where made by Tidal, that required subsequent tweaking to fix issues with Naim products. Could this be the case?

I got fed up with the unstable native Tidal integration on my NDX - having switched to using Minimserver, UPnP, BubbleUpNP and Qobuz, it’s been much better. The NDX is a great transport with a pretty basic NAS. SQ is much much better as well. Would really recommend trying it, as the flakiness of the Naim app was driving me nuts - just like you’re experiencing. Not only was it a great SQ upgrade, it costs next to nothing.

Thanks for replying, but I am afraid you assume I know as much as you do.
Could you please explain what equipment and software/app you are suggesting I try and how it differs from what I have been using so far?

Assuming you’ve tried a reboot have you tried logging out of Tidal on the app and back in again?

Do you have a NAS? If so it’s relatively straightforward - there’s a few threads with step by step instructions here telling you how to set up. Its not especially technical bur takes a bit of perseverance. Am v pleased I did persevere though. The good news is that there are a few ways to do it, none involve much money to sort, and it means you get all of the quality of the NDX in the way it was intended to be used (as a local UPnP streamer).

1 Like

First check that you are not using Tidal on more devices than your subscription allows. If you try, it won’t work.

Next I would try logging out of Tidal in the Naim app input settings menu. Then log back in and see if it works.

Workarounds like BubbleUPnP have their place, and by all means try them if you like the idea, but in most cases Naim’s native Tidal implementation works fine.

Many thanks. I have followed every step of your instructions, but unfortunately it does not work: I get the same Can’t Play message over again.

Yes, I have.

I also add that I have no issues with Spotify.

Try to restart your router first, then the Ndx. Change the password of Tidal too.

Many thanks Frenchrooster. Your tip worked and it looks like Tidal is back. Later in the day I will confirm whether it came back to stay.
Do you think something can be done to what seems an intrinsic instability of my setup?

In a separate thread I have recently created, I reported my troubles, still unsolved, in accessing or playing stuff stored on my NAS using Minimserver from the Naim App (Minimserver does not show up on the UPnP menu) or the NDX interface (Minimserver shows up, but once a tune is selected I get the infamous Can’t Play message).

Many thanks for your tips and attention.

1 Like

I don’t have Minimserver but, from time to time, I encounter problems to find the server or the app doesn’t work properly. Maybe once a month. So I restart all , first router, then server, then Nds, and I install again the app. It solves the problem each time.
Hope it will do the same for you.

Thanks. Unfortunately I am back to square one. Tidal is not working again.

I will try your procedure but any set up that requires that every month is cranky.
I use computer based software for business (it’s been 35 years now) and personal purposes, but I have never found anything crankiest than this. It is a pity because the sound and listening experience has no equal. Still the frustration erases the pleasure. And you have no one to talk to (don’t mention local dealers).

Do you use Wifi or Ethernet cables?
What is your router?

I use ethernet cables and I use a modem/router provided by TIM, a large Italian telecom conglomerate.

As you have also experienced problems with local streams from a NAS/Server it’s possible that you have a network problem. Perhaps even something as simple as a faulty cable.
As a test you could try a different Ethernet cable, and if you have any switches or other devices, remove them and connect the streamer directly to the router.
There is, of course, no guarantee that this will help, but it may eliminate a possible cause.

So the only choice now is to raise a ticket at Naim support. Sorry to not be able to help more.

Thanks. Your help is much appreciated.

1 Like

Indeed. Many thanks.

All ethernet connections are fine. Spotify Connect operates smoothly.