Issues with mesh network and Muso Qb gen 1 in app

I have two small, but annoying issues with my Naim streamers. I have a Muso gen2 (which is in the same room as a Mesh extender, and a Muso Qb Gen 1 (which is in the same room as the BT Router (latest version), both of which connect via Wi-fi . A Naim Unity Core is attached by Ethernet cable to the main router.

First issue is that the Naim app will sometimes “lose” one or other of the Musos and the only way to “re-find” them is to leave the app open for some minutes, when they generally reappear. I think I am right in thinking that the BT router and the one “disc” that I have configured act as a mesh network. The issue seems to be that the Naim system seems to not cope totally with the mesh network. I seem to recall reading that this was the case somewhere, but I can’t remember where. I am sure Naim tech support (hello excellent tech support people!) are working on this if it is the case, so I am just highlighting it here so that they are aware. I am sure it will get sorted out in a further release of the firmware/app at some point.

The other issue is again minor but annoying. I can change the name of the Muso Qb, but the change doesn’t stick. After some time the name reverts to the default. It used to work (previous versions of firmware/app, but cannot remember which). We do have the app installed on at least 4 devices and use all of them at different points in time. Not sure if that would lead to the problem?

Overall I am really pleased and impressed at how the Naim products sound and work it’s just annoying when you get issues that I cannot sort out myself!

Hi @andrewb, please could you contact (the indeed excellent!) Naim Support on and they’ll dig deeper in to your mesh issues.

Depends on what BT Hub you have. On some adding the disc is actually just adding a separate network, so can cause issues. Only the hub you pay a monthly fee for and will be supplied with the disc at time f order is a true MESH system. If you added the disc then you created a second network and will have issues with devices communicating across the two networks created.


1 Like

Well, there is only one Network SSID in the house and all devices are on the same IP network, so I assumed that it must be working as a MESH network. The extra disc was supplied with the BT router.

If using a BT Hub you should turn off smart setup in the router settings. See

So, following the suggestions here and a helpful email from Naim tech support I did the following:

All Apple devices are now on IOS 14.2.
On every device I have turned off the “Private Address” option on the network.
I have upgraded the Naim app to 5.19.4 on all devices.

In addition I have turned off the “Smart setup” option on the BT Hub.

I have also turned off “extended UPnP” security on the BT router.

Unplugged all Naim devices, rebooted the BT Router, switched Naim devices back on.

Result, much better, Qb is staying re-named, and the devices do not seem to be disappearing.


Well its been a week or so and it had been working well, but the issues seem to have come back again.

In addition when playing multiroom there are minor dropouts on the Qb.

Well rebooting all apple devices seems to help. Need to carry on testing the multi room.

Agreed I run 3 x Muso with 2 x SSID and Android controlling - all speakers Wired.
Sometimes a reboot of Android and all speakers needed.

Well, still not working properly. Need to keep rebooting Apple devices. Still glitches with multiroom (occassional dropouts). Am now trying to increase the lease time (to multiple days) on the BT router to see if that makes any difference.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.