Issues with Naim-Focal App/NDX/MinimServer

Hello.
I run the Naim-Focal App on an iPhone 13Pro (iOS 16.0.2) to control an NDX (2015 - no Bluetooth). My music is stored on a QNAP TSx31+ NAS running Minim Server, controlled by Minim Watch running on a MacBook Air (iOS Monterey 12.6).
Suddenly the Naim App stopped seeing Minim Server once the NDX image has been selected and no streaming of the music on the NAS is possible.
The other functions of the NDX are available: Spotify, Tidal, Radio, etc.
Minim Server is visible on the NDX display and, although very slowly, music on the NAS can be selected up to the individual track level, but the NDX sends a message signaling that no streaming is possible.
What kind of issue is this? It looks like there is a problem in accessing the NAS.
I would be grateful to hear your opinion.
Best
Giuseppe

There is a know issues caused by the iOS16 update where UPnP servers are not found by Naim streamers. Naim are aware and working on a fix, but for now turning on ‘Compatibility mode’ in the Naim app settings should get things working again - if this is your issue.

Go to settings / input settings / upnp, set compatibility mode to on. It worked perfectly for me.

Hello. Unfortunately, it did not solve the issue. My UPnP server is still not visible nor accessible.
I have sent the NAS for a check up to detect any issues with that.
It is really frustrating to live without any true technical help desk.
This is a serious failure, but the NDX crashing and needing a reboot is a weekly occurrence in my experience.