JRiver media server not accessible from Naim app

Dear Naim forum users,

I’m struggling to access JRiver library from the Naim app (I’m using an NDX 2). The server keeps appearing and disappearing, but lately it never shows up and I can’t figure out what’s wrong.

  • The streamer is connected to the local LAN through a cable that goes directly to the router (FritzBox)
  • JRiver (version 24) is set as suggested by @robert_h Sound quality: USB vs. Ethernet
  • The Naim app connects to the streamer without any issue from my Samsung Android tablet. I can browse JRiver library from the tablet browser as well, port forwarding and UPnP should be then correctly configured. When everything worked and the Naim app located the server, I could see “Audiophile 24 bit dac” added to my computer name in the router configuration panel. Now I don’t see that.
  • JRiver sees the streamer from the PC and I can control it from the computer
  • I also cleared the app cache a few times and reinstalled the Naim app too.

Everything seems to work, except from the Naim app. What’s missing? Any thoughts about this?

Thank you very much in advance for any advice.

In jriver:
Under media network/advanced, what boxes do you have ticked?

Same as this above?
Also have you stopped and restarted jriver itself ?

It’s exactly the same as in the picture.
I’ve stopped and restarted JRiver many times already.
I don’t have a dedicated computer for it, so I always turn off and on the computer on a daily basis right before listening to music.

It might be worth checking your firewall on the host computer, maybe temporarily disable it and see if it magically appears?

Your JRiver configuration looks fine. I use a Linn streamer for DLNA, but can’t see this would make a difference). I have JRiver MC 26.0.73.


When you run JRiver are any other apps running on your Mac?

I’d try @trickydickie’s suggestion, my Apple Firewall in System Preferences is set to allow incoming connections to Media Centre.

@trickydickie I tried that and restarted JRiver but it didn’t seem to work. I’ve also set an exception for the TCP port in the firewall, I’m using Kaspersky by the way. I’ll try once more, just in case.

@TiberioMagadino I wonder if there’s a bug in JRiver, could that be? I thought that I should try to reinstal the software. I’m using a PC, not a Mac. JRiver is the only DLNA app running

JRiver makes the library available but not with DLNA, just through the browser.

Can you disable Kaspersky temporarily was a test?
Makes sure your are not using a proxy or VPN.

Is the UDP port you have open for JRiver 5556?

Can you access your library from a tablet or phone?
http://<Your PC’s IP address>:80/GetLibrary

Does JRiver Panel work from a tablet or phone?
http://<Your PC’s IP address>:52199
https://<Your PC’s IP address>:52200

Can you see JRiver Media Server on another player such as the one built in to a Smart TV?

Just trying to establish if it is problem with JRiver or the Naim App.

You could install MinimServer V1 (https://minimserver.com/downloads/) to see if that works - if that has problems then it points the finger away from JRiver, if it works then it does look like a JRiver issue.

1 Like

I started to check everything you suggested:

  • I fully disabled Kaspersky and tried with and without my VPN: no results
  • I can’t access the library typing: http://<Your PC’s IP address>:80/GetLibrary
    The browser reports “connection refused”
  • This address works without any issue: http://<Your PC’s IP address>:52199
  • This address doesn’t work: http://<Your PC’s IP address>:52200
    The browser reports “connection refused”
  • I have no Smart TV to test it with, sorry
  • I will surely try MinimServer V1 if I can’t figure out what’s wrong with JRiver

According to what the browser reported, I tried another setup:
I left everything turned on (Kaspersky and VPN) and manually opened ports 52199, 52200 and 5556. It seemed to work instantly. Then, after 5 minutes, it stopped working again.

This time I decided to leave the automatic UPnP management on for the ports and disabled the VPN. Again it worked instantly but, after 5 minutes, it stopped working again.

So is it the Router? Maybe just the VPN?

I still can’t access the following address anyway:

  • https://<Your PC’s IP address>:52200
  • http://<Your PC’s IP address>:80/GetLibrary

Finally I restarted JRiver and I can see it on my tablet ( I didn’t change the last setup I mentioned). I wonder how long it’ll last! I hope to get all this sorted out for once and for all

1 Like

A quick update @TiberioMagadino: I noticed that JRiver does disappear from the tablet when the VPN automatically turns on. So I think you basically found the answer to my problem (a huge thank you of course!). However I can’t really figure out why it worked at times even with the VPN turned on.

Still, something isn’t correct, I should be able to access these two addresses:

  • https://<Your PC’s IP address>:52200
  • http://<Your PC’s IP address>:80/GetLibrary
1 Like

Hi, the tcp address 52199 I think is just for external access, so you can open that port on your router, link it to your device’s internal ip address, and then for example use JRemote over the internet.
You can also try your.local.ip.address:52199/Panel to access jriver via a browser.

Hi @robert_h, you might be right, I’ve never tried that. I guess you need a static IP to make it work. I’ve only used JRiver to listen to music locally with my previous DAC and also to watch blu-rays . So I’m not fully aware of all its features to be honest but thanks for sharing! I’ve always appreciated it for its sound quality.

A bit off topic… can I ask you if you know how to change the thumbnails resolution? When I enter each album from the Naim app, the quality is awful. A good resolution is loaded only when you play songs. I didn’t find anything about this so far.

http://<Your PC’s IP address>:52199 is the JRiver Panel server. It lets you play music on your tablet or on the music server. I use it to play music through my Chord Coral system. My music server being a Mac mini connected over USB.

https://<Your PC’s IP address>:52200 is also Panel, but will only work if you have enabled SSL in the Media Server setup as it is a secure connection to the JRiver Panel. You don’t need to worry about this because as @robert_h says its main use is if you want to access JRiver remotely (my slow Internet connection and the need for an externally routable IP address deters me). It does work on my home network (using a self signed certificate), but not something to concern over.

1 Like

I only listen to music locally, so it’s not a problem for me. I wonder why http://<Your PC’s IP address>:80/GetLibrary isn’t working correctly, never mind as everything else is fine.
I hope there’s a way to use both the VPN and the DLNA server at the same time.

A vpn would be for external traffic so shouldn’t impact an internal lan and dlna. The impact of a vpn I think would only be against jriver’s external connection which I don’t think you are utilising. By default a vpn connection would be blocking 52199 so jremote or jriver running from another location eg at work would not be able to connect to your pc running jriver at home.
In the past I’ve used jriver internet streaming ie running jriver at the office and connected to my jriver instance running at home. You can only do this if your vpn lets you open a port. Assuming the pc at home is using a vpn connection. (The default is 52199 but can be changed if needed to match with your vpn).
On your internal lan connection it shouldn’t make a difference.

If you can play music in jriver with the ndx2 selected as an endpoint then the setup should be correct. Why the Naim app isn’t working in reverse ie seeing the jriver dlna server I’m not certain. I’ll have to experiment to see if I can break it here.

Ok it’s the first “tick” here “dlna server”; untick and jriver disappears in the Naim app. Didn’t need a restart of jriver, just tick/untick and click ok.

And you still have the dlna server definition as follows? Maybe try removing it and putting it back again.

The only other possibility assuming everything is set up per above screenshots is there’s a difference between v24 and v26. Though I’m pretty certain I’ve used 24 (and possibly older) with my unitiqute.

I think this is the download link for the last build release of v24 for windows.
There are mentions of fixes for dlna in the comments, no idea if this could have caused the issues you are experiencing.
I’m running v26 build 26 on Linux.

1 Like

For the Naim app to see items it must see the responses back from DLNA clients using the discovery multicast group IP address If the JRiver is not responding to any such group query for what ever reason then Naim won’t see it.
This could be a firewall setting or IGMP snooping error on your JRiver host.
A cheap effective app to help diagnose is Net Analyzer… an app for the iPad. Tell it to do a network scan, and a ‘U’ should appear by the host running JRiver.
If not that group address is being blocked. If it is and you still can’t see a JRiver, it’s either a JRiver problem, or incompatibility with the Naim app.

1 Like

Apologies my knowledge of Windows is very limited, but according to JRiver Wiki if you are having issues with DLNA discovery then you may need to turn off Windows Media Sharing services.

  1. To disable the service, use Computer Management (right click on Computer select “Manage”).
  2. Select the Services tree from “Services and Applications”, find “Windows Media Player Network Sharing Service”.
  3. Right click on the service, select Properties.
  4. Click the “Stop” button to stop the service if is is running.
  5. Set the startup type to “Manual”.
  6. Click OK.
1 Like

@robert_h I agree with you, at least this is what should happen. I suspect that the VPN is changing other parameters, it has to be blocking port forwarding. JRiver can locate and control the NDX 2 in the local lan even with the VPN turned on. That doesn’t work viceversa, the Naim app won’t locate the DLNA server unless the VPN is off.

Everything is setup as in your pictures, except for the TCP port (which is the standard 52199) and “DLNA renderer” which is now disabled (it didn’t make any difference).
I ticked and unticked “DLNA server” and it worked as you said, but that only works if the VPN is turned off. When it’s off, everything remains stable and works properly (I only experience a lag when I need to access the music library, but it’s a matter of moments).

Thanks for link, I was pretty sure to have the latest version installed, but I discovered to have the 24.00.75. I just installed the latest one right now.

@Simon-in-Suffolk That’s a very interesting and useful app, unluckily I couldn’t install it as both my Android tablet and iPhone are too old for that. Do you suggest any other app or method? I’m very curious to check that. I think you might have found my problem.

@TiberioMagadino No worries, on the other hand I’m not an expert with Mac. "Windows Media Player Network Sharing Service” is already turned off in my computer, so I can’t really blame that.

Right now I’m pretty confident that the problem is the VPN blocking port forwarding.

Depending on your vpn provider, you may be able to open port 52199 or another number; update the number in jriver if needed. Some vpn providers don’t support port forwarding. There’s another option, again if supported by your vpn, of allowing an application to run outside of the vpn, I think it’s called split tunnelling.

1 Like