Lag time with Qobuz in Naim app

I have been noticing long lag times while navigating Qobuz in the Naim app. It varies from slow to at times,frozen. I do have about 100 favorite albums. I tried logging out and back into Qobuz. I have an ND555. Strong internet service about 100 mps Ethernet. Tidal and QNAP files not at all affected. Any thoughts?


That’s strange with just 100 favorites. There was a known issue with more Qobuz favorites (I have 2000) where the app was unresponsive on every wakeup. However, a number of general performance improvements in the recent app update a few days ago improved this issue a lot (not super quick but no unresponsiveness). I described this issue at the below link but yours may be different. In any case, make sure that you have the latest app update.

I just reported the following to NAIM support via email.

Subject: Naim App on iPad using Firmware 3.6.0 (5106) with iOS App version 5.21

I noticed in the past couple of days that when using the search function in Qobuz that the search feature on the Naim app drops ‘Local Music,’ ‘Qobuz’ and displays ‘Radio stations’ only when selecting ‘search’ on the keyboard.

When opening it displays”Search: Radio stations, Local Music, Qobuz”.

Then typing a search like ‘Floating Points’ it returns with no results returned immediately and ‘Radio stations’ only displays.

At times after a delay results will then appear. Just noticed this happening recently but have seen some comments on the forum of others experiencing the same results when using the search feature.

(end of email)

I suggest everyone who is experiencing any issues with search in Qobuz drop support an email.

Curious I have not noticed this at all… just did the example Floating Points search and got a page of responses almost immediately…
I wonder if it’s some sort of timeout thing if your network or Qobuz library management is busy.

Qobuz had some response-speed issues last night (April 7 PM) which may be what has been experienced. More detail here.
All seems fine at the moment.


I have noticed a delay with quobuz screen loading, but it varies depending what device I use. Amazon tablet is very slow, android mobile phone is a little slow but acceptable

Wondering if there is any new information on this topic. Qobuz continues to be very slow or at times frozen when navigating in the Naim IOS app. I have about 100 favorite albums in Qobuz. Navigating in the NAS/UPNP and Tidal is fine. ND555 is hard wired with a good connection of about 100mps. WiFi for the iPad is also good.

Is it just your Favourites that load slowly or other large groups of Qobuz items?
E.g. What happens if you go to the Qobuz source and load up:

  • New Releases > More > Qobuz Grand Selection > More

Thanks for the reply. It happens with all aspects of Qobuz navigation,including loading a selected album even if not in favorites for example new releases etc.
BTW I do have the latest iOS version of the Naim app.

How does the Qobuz app itself perform?

No problem with the Qobuz app everything loads quickly

As I use Roon I disabled Qobuz in my Naim app as it was taking so long to authenticate and to connect each time I wanted to use the app. As soon as I turned it off then it loads and connects instantly no lag at all. I do have over 2k favourite albums in Qobuz so maybe the reason. I might try and see if these updates have @Suedkiez mentioned have helped as I don’t use the Naim app much but when I do I want it snappy.

Just tried it again and wow what a marked difference it connects really quickly now, a bit of lag browsing but nothing major.

1 Like

It is a bit odd. To recap, I also have 2000 Qobuz favorites and there were originally seconds of lag/unresponsiveness every time the app woke up (I have Android). This was the main reason I started to look for alternatives and found Roon. So I am not using the app much anymore, but kept an eye on the problem.

The latest app update to 2.21.0 definitely helped with this issue, the unresponsiveness disappeared nearly completely. (Still not super fast, but at least responsive).

Then, during the last week or two, I suddenly experienced unresponsiveness again. Upon a closer look it turned out to be a bit different. What happens now is that the app continues to be responsive directly after wakeup (e.g. going to homescreen and back to app) as it had been since 2.21.0, but then goes unresponsive a few seconds later, which lasts another few seconds until it recovers. This is happening most of the time now but occasionally it does not (see next paragraph); when it does, it is reproducible every time after wakeup and I reported it to Tom in the beta group. As there is no reason why the app would suddenly change behavior, it is possible that it is an issue with the Qobuz server responsiveness. (Or possibly my devices/network but nothing changed there)

So, to @tomvamos, another update from me on this: Oddly, this new behavior was not reproducible on Tuesday evening after I received a possibly coincidental Android security update on the tablet and rebooted. (Previous reboots had never made a difference, and it also was not repro at this time on the phone without rebooting). I already wanted to send you an update about it but thought I would try some more on another day. Now I did, prompted by this thread, and right now the new lag is back again as described. :man_shrugging: (on both devices, the tablet and the phone)

1 Like

Yup. Same here, if what you mean is, when for instance, scrolling in “my artists” on Qobuz from within the Naim app, the screen lags. Or as said by others, when searching there is a lag before all the search sources appear. And, yesterday I had to do…my apparently weekly hard re-set…which is a pain…but. Just now I checked and no lag. Things are working well at the moment.

All these problems? Nada with AppleMusic. If they added hi-def there’d be no competition. I love everything about it. If I’m playing an album, Apple plays similar music. If I want to hear a random mixture of my stuff…bam…unbeatable.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.