Latest Asset breaks Asset menu & Album covers

Just wondering if anyone else is experiencing broken Asset menu icons & album covers have installed latest version of Asset for Synology DSM7. The issue remains have installed latest version of IOS to 16.5 on both IPad & IPhone.

Have cleared image cache & rebuilt database in Naim app but no improvement. Have also performed similar via Asset in DSM but again no change

I have posted a thread on Asset forum so will post any update from there to here in case anyone else here is experiencing the same

Examples attached

No issues here but I’m on QNAP and iOS.

The audio gods are pointing you towards a listen to Polly Jean :+1:


I have no problems such as your screen shots show.
My system is Synology DS214 with DSM7 & iPad with iPadOS 16.5.

My only problem is some icon defects with Composer & New Albums, the problem looks like the same but nowhere near as bad as Gordy.
I too have reported to the dBp Asset forum

Ooh, yes. I updated yesterday, but haven’t tried to use it, but seem to have the same issue as you. Not spent any time investigating, but did try to edit the browse tree and reset to the default, but no difference. I get the issue with the same letters (I L M Q U V Y) in Artists, Albums and Title and Composers

thanks @Gorby for raising this issue with Asset - let’s see how long they take to respond

I’m not seeing this at all, I updated yesterday.

Out of interest what does your browse tree look like?

`Here’s mine:-

Type\Album Artist{_no_track_list_}
Type\Album Artist\Album by Release
Type\Artist\Album by Release
Type\Compilation\Album by Release
Type\Composer\Album by Release
Type\Genre\Album Artist{_no_track_list_}
Type\Genre\Album Artist\Album by Release
Type\New Albums
Type\Top Albums
Type\Top Artists
Type\Top Artists\Album

Bingo just ticked the A to Z in the browse tree options and now I see it.

If you untick the A to Z in the browse tree it should look better till they fix it.

1 Like

@Gorby Did you uninstall and install 7.5, my posts on the Asset forum keep disappearing ?

1 Like

Yes i did thanks - have just updated Asset forum - their last post was as follows & it worked for me

Re: Latest Asset for Synology broken Asset Menu & Album covers

Does downgrading to old Asset R7.5 help?…DSM7-trial.spk

(Trial version will act as registered if installed on top of registered)

Make sure to clear any caches of your iPhone/iPad app before testing, could still have local copies of malformed pictures.

1 Like

Did it keep your settings after the uninstall ?

I had already gone back to default settings in Asset , when attempting to solve it previously, so cant confirm if it retains the settings

1 Like

As my system has only minor effects with this bug, which is strange in itself, I’m sticking with the new version and will wait for the bug fix.

Note to QNAP & other non-Synology NAS users, Illustrates Peter-P is asking
Has anyone else seen this bug running Asset on something else than Synology? Because Asset program itself is the same (same actual program binary) for plain Linux / Synology / QNAP, so if it’s a bug in Asset it should be apparent on all of these not just Synology.

1 Like

I didn’t update. No issues so I’ll hold off until the next release just in case. I’m usually pretty late to update normally.

Illustrate’s guru PeterP has posted on the Asset forum thread that he’s found the problem ……
“ Well, this is embarassing, SOMEHOW Apple ._ files from development Mac made it to the SPK.
This wasn’t happening before, and my scripts didn’t change. This bug happens even if I rebuild old versions from source, so it’s introduced when packing SPK on my machine, not by some changes in my code. I’m still investigating the exact cause and a fixed build will be out shortly.”

He’s posted a patch if anyone’s interested, go to the Asset thread.

1 Like

Thanks Mike, it would appear to work.

Thanks Mike

I tried the work-around. Successfully deleted the files, restarted Asset, no change running the app from my Mac. Powercycled NDX2 and then laptop - no change. Did a full Asset rescan, no change. Ran app from my phone, works fine. I’m guessing it’s some sort of app caching that takes place, but would have though a reboot would fix that

Try in the Naim app Other Settings → Clear Image Cache

Spot on - fixed it :blush: thank you