Latest Naim App Only Searching Tidal

Hi All,

Is anyone else having a similar issue with the latest app update? I’ve found that regardless of whether I’m browsing my local upnp music the app just gives me results from Tidal. This means I have to scroll through the list of artists from A-Z of my locally stored music just to find anything. Only updated today and I think is the first time I’ve tryed to play UPNP since the update, I have to admit it’s already got very frustrating as 80% of my music listening is via UPNP.

I’ve restarted my phone, NDS and to be safe minimserver on my NAS.

App is on Android Pie
Streamer is an NDS running FW

Strange I’m the first to post about this issue but hopefully someone here has got a solution or some advice?


Hi @loks strange you posted this, I raised it with HQ in the Beta testing group yesterday too.
I’m not sure if it was always like this or if this is something that has been introduced recently.
If you drag the view (eg. The list/tile view in Music Servers input) downwards to reveal the toggle between list and tile view, you also get Filter. It’s a dynamic filter which effectively does the same as Search but only for the view showing. I don’t know if this is meant as the Search for UPnP.
I’ll see what HQ come back with.

Thank you for that Chris, that does work, phew :slight_smile:

Probably still needs to be addressed as a design fault, I would have thought search (magnifying glass) should search your upnp server when you’re actually browsing it. I even disabled Tidal as an input to test and it still only gave me results from Tidal when using upnp, so could be a bug.

Just glad I’m now able to search upnp though, thank you for your help!


1 Like

I’m glad you posted this, as I thought I had lost the plot!

1 Like

I would also have thought Search was a universal Search too, it’s the more intuitive word and function being as the magnifying glass is always visible.
Glad you’ve got a workaround for now though!

I can drag down the second “filter” bar, but can’t enter text into it, so searching is limited to Tidal and not your library.

One for @NaimAdmin please.

Hi Mike,

I also thought Chris’s solution didn’t work initially, try changing from list to tiles and back, cannot explain why it works, but for me it did. Hope it helps.


Still no luck after maybe toggling between views @Mike_S ?
I dont remember having an issue with that and am able to enter text into the Filter line OK.
Ive flagged this thread to HQ in my Android Beta testing posts.

1 Like

I closed and relaunched the iOS app and now search is working across Tidal and the Core, with options for either or both…

I find the filter option works fine in uPnP lists but if you have a Tidal favourite album list displayed, drag down to show the filter box and then attempt to click in it in order to enter text, the app closes.

I don’t know whether it was intended to offer the filter option or not for Tidal favourite lists but clearly it shouldn’t just crash.

IOS V5.12 on iPhoneX and Muso.

I should probably clarify.
Myself and @loks are running Android and it is this that I have reported back to HQ in Beta Test as closing and relaunching doesnt work in restoring the Search functionality across the board in Android.
Great that you now have the (presumed) correct Search functionality now though @Mike_S!

Im not sure re. your issue @Steeve but this thread has been flagged to HQ so Im sure they will pick it up.

1 Like

Hi, yes I appreciate my issue is different and yet along similar lines. Out of curiosity, although it doesn’t help me, do you know if the Filter on Tidal favourite lists works on Android?
It would be a useful feature as I have accumulated quite a long list now and there is no other way to access something except scrolling down.

Ill have a look later and report back.
Unfortunately Im at work :flushed: so cant check it at the moment…

1 Like

I’ve just checked it @Steeve and Filter in Tidal Favourites does work ok in Android, at least it does on my Moto G5.
I’ve also checked on my iPad in iOS and it doesn’t crash on my device - sorry!
Maybe it has something to do with the big number of albums you are filtering in your Favourites?
(If you are filtering in Album view it only filters by album titles though so it’s not a full search of artist and title.)
Hope this helps for now.

Just wanted to add and it might be a bit premature as I’ve only been using the app for 24 hours, but I’m definitely finding the Android update more responsive and it hasn’t skipped a beat in finding minimserver on my network, something the previous version would regularly fail to do.

So with the search workaround and added stability, I’m very happy with this version, big thank you to developers and testers!


1 Like

Hmm…thanks for checking anyway!
I tried to test out your ‘too many albums’ theory as the filter does work ok on Tidal playlists but on Albums, Tracks and Artists it crashes as soon as you click in the box even with just one or two items in the list. @naimadmin Any thoughts? I’m using the very latest iOS version 12.2 on my iPhone X.

Just to confirm, my issue has now been acknowledged as a bug and hopefully should be fixed in v5.13 of the iOS app.

1 Like

This too is my experience since updating the Naim App to v5.12.1. In my case, the devices crashing when I access the ‘filter facility’ on the Tidal ‘My Collection’ screen are an iPad Mini v12.2 iOS, and iPhone 5s v12.2 iOS. However, the ‘Playlists’ filter works fine. Am looking forward to the fix.

Hello does anyone know if the UPNP search fault has been acknowledged as a bug on android? I’m using the work around suggested on here but slightly frustrated at the moment!

Thanks in advance for any help/replies.