Latest update to the app has a lot of problems

There seems to be a lot of problems with the latest version of the app and software update. If you set up a playlist and then decide to delete unplayed odd tracks it regularly crashes the app. Streaming internet radio is not updating playing tracks correctly. All worked fine before the latest update. I have cleared the app cash data, I’m busing Android devices. Same problem on two different naim sources, unity atom and Nd5 v2

All noted. Let’s see if we can rule out some things can could be causing problems.

Firstly, you mention you are on Android - are you running the latest version of the Naim App (2.22.1)?

Once you are, restart your Android phone/tablet - full power down and power back up.

If you still having issues, I would move to power cycle your Naim devices - unplug them from mains power, leave for 30 minutes and then reconnect.

While you’re having that 30 minutes downtime, I’d suggest a router restart, to rule out network issues.

Yes latest version of all software. I never leave any equipment powered up when not in use, so yes it has all been power cycled several times, including being powered down over night. No net work issues, I work in IT, so very computer and software aware. All problems started after recent update, before then, these problems did not exist.

Thanks for quick reply.

Thanks - I hope you appreciate we can’t assume people are as savvy as yourself!

I would contact our support team - - and include a link to this thread, so they know what you have already tried.

They can run product diagnostics to look into things.

i just updated to firmware 4.8 for my superuniti and it cannot play any tracks. says error use naim app on my superuniti.
any ideas how to solve this?

1 Like

Have you performed a factory reset? And are you running the latest version of the Naim App (5.22.1 for Apple iOS or 2.22.1 for Android devices)?

1 Like

I logged a ticket for this but I have not had a reply. I see there has been a couple of app updates but the issue I reported is still not fixed. I think it might be worse as the app can hang very often, it says we are playing a song from several songs ago i.e. not the current song playing. Close the app and open again and it is correct, a couple of songs later, same issue. Never had this problem until the one but last update. Do Naim see this problem, or is it just me? 100% not my network, or infrastructure. I was thinking of trying a factory reset, but this is a pain and something I should not have to do after an update. The system ran perfect, never a problem until the last firmware update and associated app update.

1 Like

Yes, factory reset is painfull.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.