Linux sound output

I use a Linux computer as one source (ArcoLinux) and until quite recently this has been into a non-Naim dac or a Cambridge Minx Xi and worked fine.

A couple of upgrades later though and I have now a SuperNait 1 and a UnitiQute 1 and there’s silence from both devices, using a Toslink optical cable. The Naim app for the UnitiQute reports ‘Digital Signal Locked’. The UnitiQute has firmware 2.0 which I’m hoping to get updated soon.

As far as I can tell, and I’m not an expert by any means, the PulseAudio config is correct, but I must be missing something. I know Naim require a PCM stream, and my config reports.

; default-sample-format = s16le (PCM signed 16-bit little-endian)
; default-sample-rate = 44100
; alternate-sample-rate = 48000
; default-sample-channels = 2
; default-channel-map = front-left,front-right

Can someone help figure out what’s missing for this to work? Thanks.

2.0 is a very early firmware version from which it is not possible to upgrade to the latest.
I can’t see any obvious reason why this would prevent you from playing regular PCM stereo up to 24/96 although I know nothing about the Linux computer you are using.
As a test, can you copy an album onto a USB memory stick and see if that will play in the Unitiqute?

It might be the pcm format, what other options do you have available?
It’s not quite the same, but I have jriver upnp running on Linux, and the output format that works with my uq2 is pcm 24 bit. The L16 and L24 options don’t work.

I’ve only just got the UnitiQute, as soon as I can I’m going to get the firmware updated though I’m pretty sure this isn’t the problem. It’s the S/PDIF feed out of the computer I need to fix.

Thanks, I’ll try the 24 bit option. I didn’t think of that, I was looking for trying to make it like a CD standard.

As I mentioned above, Naim advise that a streamer running a very early firmware version can’t be updated, and if you attempt it you will probably end up with a defunct streamer.

Try taking a PCM (WAV) file and converting it to FLAC and see if that plays. Assume your linux system has the flac libraries installed.

Another suggestion.
Convert a WAV file to FLAC and then convert it back to WAV using the “flac” and “flac -d” commands. If there are errors in the original WAV file the flac commands will try and repair them.
flac myfile.wav
mv myfile.wav myfile2.flac
flac -d myfile2.flac
[myfile.wav and myfile2.wav will probably be different]

I had a typo in the last reply. It should of course read …
flac myfile.wav
mv myfile.flac myfile2.flac
flac -d myfile2.flac
[myfile.wav and myfile2.wav will probably be different]

@Bonang @robert_h Thanks for your suggestions. I have managed now to fix it, what I did was first boot from a live CD and the sound worked from those default settings. So I simply did a re-install which is quite a quick process and all is good again now.
I still can’t find any difference in the before and after settings, but the main is it’s fixed!