Lost the lot when connected to router via ethernet

The Naim app loses connection and cant find room when I connect the ethernet cable direct to router. Got an IT expert in and he is baffled, as soon as you disconnect the cable you can then get contact back. I have the Naim app on a galaxy tablet. I thought i was doing the right thing by connecting direct to the router as I wanted the benefit of the tidal master quality. I also believe I cant get this on android or direct tidal on the muso.
I’m a novice to the Naim family but a little dissapointed . Any help would be appreciated

1 Like

I don’t understand how you have this connected, maybe have another go at describing your setup.

Any music stream is from the broadband hub to your Naim unit, the app is not in the data stream, it’s just a display & control unit. & the tablet is connected over wifi.
The Naim unit is a Muso ?. That is what you must connect to the router?
Apart from streaming www music, do you have music on a local server = NAS or other storage, if so this is how to connect it.
If no local server & only streaming from www, then just the connection router to Muso

Thanks for the response Mike. I’m not good with tech. I have wired direct from the Muso2 to the router direct. No other devices connected to the router. My galaxy has the naim app for controlling the muso. As soon as I connect the cable the galaxy naim app loses the unit. Says cant find room.

When you say - as soon as I connect the cable (to the Muso) the Naim app on the Galaxy loses the unit. Says cant find room.

I don’t know Muso so it would be best if a Muso user chips in.
It might simply have its wireless link confused & a thing to try is power it all off, leave it off for 5 mins. Power up the router & let it finish its restart process, then the Muso, then the Samsung.
If you have had an IT person playing with it, ask if he/she changed the IP address mngt to Static. That not a good idea & it really does need to be left on DHCP (the factory default)

I have my Muso 2 directly connected to the router and use iPad and iPhone for the app with no issues.
When you connect the router cable what colour is the led on the side of the unit?

It sounds to me as if somehow your WiFi network is on a separate sub-net or even a separate network to the wired connection from your router. That could explain why the muso2 works when connected by WiFi but doesn’t if you connect with cable.

I think you need to explain more about the router. What is it and where is the WiFi connection coming from? Is it the only WiFi connection you have in the house?



1 Like

This seems logically

@Kenny64 are you able to find the IP address of your Muso when wired and your Galaxy. If you can also find the subnet mask for both this would be useful. Sorry I have an iPad rather than Galaxy, but hopefully what they call these patameters is the same.

These data will show if your wired Muso and Galaxy are on the same network. Apologies if your IT expert has already done this. Your wired and wireless network need to function as one combined network for everything to work well.

The other thing to do is to make sure you have a good Ethernet cable. Nothing special. Simply check it works well with a PC or Mac or TV or you can use your MuSo with it without using your Galaxy. A few years back I had a similar problem with a Sonos box and simply changing the Ethernet cable to the one that worked with my laptop solved it.

Ok I think I follow you… with WiFi it all works, when you plug an Ethernet into the Muso your app then can’t see the Muso?
If so that suggests your Ethernet link is either faulty, separated from your WiFi LAN, or your Muso Ethernet link is somehow faulty.
If your expert really is an IT expert they will be able to confirm this very easily.

There is a free programme called Net Analyzer, at least for iOS, might also be for Android. Load it or similar (use your expert if necessary). And when you plug your Ethernet lead to Muso check you can see the Muso on your device analyzer app when you tell the app to scan the devices active on your home network.
If you can see it, then the issue is Muso/app related. If you can’t then it’s either an issue with your WiFi router, switch port or Ethernet lead, or albeit unlikely faulty Muso Ethernet hardware.
Your expert, again if truly an IT expert can trace this down quickly.
Most likely is bad setup of WiFi router or faulty Ethernet lead.

This is what my Qb looks like with Net Analyzer on my iPhone when connected with Ethernet.

1 Like


I am said “IT Expert”

The issue is not with the network, router or cabling.

The issue is purely a an App issue, and specifically the app for the Android platform.

All works fine wired or wireless when running on the iOS Platform.

Doesnt matter if IP is static or dynamic, or added manually on the app, it still does not function when the speaker is ethernet connected and access is tried from an Android device.

In addition i think its poor that with such an expensive unit the only way you can truly play master copies of music is through Tidal and again the iOS Devices.



This all works fine for thousands of Android/muso2 users, so it’s something specific about the setup there. As it’s all ok with IOS it’s probably that the particular Android device isn’t playing well with the Naim app. Maybe you could temporarily try another Android device to check that out?



I’d like to know the meaning of those letters and numbers enclosed in the colored square on the right …

Have agree with David, thousands of satisfied users can’t be wrong.
Someone I know has a Muso since they first came out & recently added a Muso-2 in another room.
He uses the Android app on a tablet (I think its Samsung) & an iPhone (iOS app) His wife & kids also have s.phone control points, but not sure what app.
I helped him with the multi-room & local server setup & last time we spoke he was very happy with it all.

You can play better than Tidal, e.g. real hi-res (24/192) PCM or DSD from your own local server (NAS)

W there is a web page
B means Bonjour services are supported/seem
U means UPnP services are supported/seen
6 means ipv6 addressing is seen
P means it’s pingsble using ICMP


Thanks for all the replys and help. Genuinely appreciated will keep trying,dont want to give up.

What is the router please?

The router is usually the box that connects to your broadband circuit as it comes into the house and it usually provides WiFi in the house. There are some sockets on the back which can take ethernet cables which have plugs that are square with all the contacts on one side. It can be separate from the modem but if you know nothing about it then it’s probably all in the one box provided by your Internet Service provider who you pay for your broadband service.


Hi David. Awesome thanks! I actually install networks as part of my job, so this was a brilliant refresher for me haha. I actually MEANT ‘What brand of router is it’. Haha all the best.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.