Mac experts - help sought - SSD dead

With what seems to be immaculate timing, my MacBook Pro gave me the white screen of death last night.

Trying all the usual things, I could only get the question mark file icon or else internet recovery. Disk utility tells me I have no hard drive. Removing the SSD and trying it in a usb caddy also shows no drive in disk utility. So I’m beginning to think it has failed catastrophically.

Before I throw in the towel are there any other ideas for recovering the SSD?

The SSD is a Crucial 1tb.

Richard, are you aiming to recover data from it or just repair? Bad luck BTW

Hi Richard,

Although your having tried the SSD in a USB caddy, with no luck, does point to an SSD failure, when my MacBook Pro crashed, with the same question mark icon on the screen, the problem, in fact, turned out to be a failed control chip on the motherboard, which also was preventing the USB sockets from working.

I sent it to MacRepair in Leeds, and the problem was soon sorted. They are very good at what they do, and are a franchise of iFixExpress, who might be a bit nearer home for you.

Bad luck, and less than perfect timing with the approaching holidays, but hopefully you manage to resolve things quickly, and with minimal expense.

1 Like

Hopefully both, but I do have a recent time machine backup from a few weeks back, although ironically the latest was on my list to do today.

Sorry to hear this, it’s a sickening feeling isn’t it.

The only other thing I can suggest is using an external USB controller and connecting it to a different machine using a different OS.

Very much a long shot - I don’t hold out much hope, it’s most likely to be a total loss.

That it should fail immediately before you were due to do another backup is the just the inherent cussedness of inanimate objects!

I tried to see it while connected via sub on a windows machine and nothing shows up.


Sorry to hear of the problems. I would not expect to be able to see a MacOS volume in windows as it is using an Apple file system.

You could try shutting down your Mac, then turn it on and immediately press and hold these four keys together: Option, Command, P, and R. You can release the keys after about 20 seconds, during which your Mac might appear to restart. This flushes the PRAM (Parameter RAM).

Then try booting your MacBook in Single User Mode by holding down Command+S during system boot after you hear the boot chime, you know you will have successfully entered Single User Mode because you will see white text on a black background

When the Single User boot sequence has finished, you’ll be at the command prompt prefixed by a hash sign (#), when you see that type this command to run a file system check.

fsck -fy

Once fsck completes, if you see a “File system was modified” message, then you should run “fsck -fy” again until you see a message stating “The volume (name) appears to be OK” – this is standard procedure of using fsck

Type “reboot” to leave Single User Mode and boot into MacOS.

If no luck with this then I would start in recovery mode. Reboot and hold down the Command and R keys until you see an Apple logo or spinning globe. You will see the spinning globe if the Mac is trying to start macOS Recovery via the internet because it is unable to start from the built-in recovery system. Eventually your Mac will show the Recovery Mode Utilities window from which you’ll get some options to recover your disk.

Hope this is of some use.


Thanks, yes have tried all those apart from single user boot. No dice.

I did read that SSDs can sometimes get “stuck” with a firmware corruption. If you power it up for a while without the data connection it might reset itself. Wondering if just plugging it into a usb charger would do the trick. A long shot…?

It’s possible and worth a try. Sorry the above didn’t work. It does seem your SSD has a hardware fault otherwise I’d expect Internet recovery to have got somewhere.

Absolute nightmare Richard - been there but on an old 2012 MacBook Pro with a standard HD. What age & model is your MacBook Pro? Just wondering because my 13" and 15" are 2017 models so hoping it’s not a common problem. Fingers crossed you can sort it out.

It’s my original mid 2012 model. I upgraded it though with extra RAM and an SSD from Crucial about 2 years back. Was working great until safari crashed and I got the WSoD. I was moderating they forum at the time. I assume it was just coincidence… :slight_smile:


By the way, thanks to all who have so far replied. Much appreciated. I have the iPhone, the iPad mini and also a couple of windows machines to tide me over, although the MBP is my main unit. I’m cooking roast turkey and all the bits for 10 people on Wednesday so I’ll need to put the mac on the back burner for a few days at least.

1 Like

If you put it on the back burner while you cook
a) the case will melt
b) you’ll definitely wreck the SSD

1 Like

If the disk is OK, a Widows system will see the disk and read the partition table, it just won’t be able to see the file system.
This has the advantage that it can’t be confused by errors (or Mac viruses) in the file system.

You can set these to run automatically and double your backups using iCloud. You can never have to many backups.

Good luck. I’d have thrown it out of the window by now.

On the windows machine, did you try to find it just using explorer or did you go into disk management? (MyPc/rt click/manage/diskmanagement)

Thanks, my knowledge of Windows is scant to say the least.

Just into explorer. I’ll try disc management.

I had a problem a few years ago where an SSD failed. However it wasn’t the boot disk and I could get it to mount, I used a piece of software called ‘Alsoft DiskWarrior’ which recovered most of the files.

If the SSD is completely dead then this won’t help…

So, i got a new SSD and tried a recovery from my Time machine back up. However it went glacially slowly, to the point where I only had 450mb and it was telling me it would take over 1000 hours to complete. That can’t be right so I aborted. I’m now trying an internet recovery, which is risky considering how poor the internet can be here. I do, however, suspect some other issue at play here.