Melco Server Help!

I’ve gone in a loop a few time with this problem I have had today - lockdown and lack of access to any help right now means I’m struggling more than I want. Since I have no music and have been going in a loop for hours - if anyone with a Melco Server can assist I’d appreciate it.

I use mine in the mode where it is supposed to connect to my house Network and get a dynamic address via DHCP and of the kind 192.168.1.X and it in turn connects to my ND555 Server which does the same.

Presently I can’t get it to behave or give me the right DHCP sunnet address and it is blocking access to the ND555.

Can anyone give me a step-by-step procedure to run through the settings on this to get it to connect to my house network - get a DHCP address - and just work! :rage:

…These are the days when I which I still had a CD Player…

Thanks in advance it anyone can help.
I’m too close to this for perspective I think to get it fixed and it is getting dangerously close to being thrown out the window. :bear:

…the thing that began this was it accidentally losing network connection today - lead pulled - and then it just never was happy - now it is psycho.


Take out your etheregen and connect direct to router or other switch see if it helps. Reduce the box count I between Melco and network to see if any of them are the issue.

1 Like

You could try setting a fixed IP address on the Melco. You can do this from the Melco (settings/network/ lan/ dhcp or fixed) or from your router.

Also worth checking that the Melco is still in bridged mode (settings/ network/ player port).

That did help - in now picks-up an IP address - and the right one!

…still have a few other problems with it all but progress… :upside_down_face:

Now the Melco acts as just a by-pass - I don’t see its Server for music but it is out of the way and allows the ND555 to rout to other backup Servers I have - and these I can access and play music from.

The ER switch may have not been happy with losing power briefly a while ago - I’ll check it specifically later once I restore Melco operation with the Cisco 2960 that is working for it now.

DB, i am quite sure you have tried but I personally sometimes loose the Melco server.
I restart first my router, wait till Ethernet is back, then restart Melco, wait, then Restart Nds.

That is next to try.

Presently the house Router is giving the Melco and ND555 a correct address and I can rout past the Melco to another NAS server and play music - so that is a big positive I did not have for a frustrating while!

I tend to not like re-starting the Melco too often as it seems to go into a default node or re-scanning 3TB of music before it allows me to do anthing and it takes hours - not my favorite feature of the device.

But that is next…


Mine takes 5 minutes to restart and stay with the right settings. I have to do it maybe once per month when I loose it on the app.

1 Like

In my experience either lots of fiddling with cables (moi?) or a simple circuit breaker power outage (like from a cooker hood lamp blowing up - don’t ask me how I know), can cause the EtherRegen to have a merry strop when everything comes back on again. Powering off for a while (simply pulling out the DC plug, waiting a little while and plugging it back in again) gets things back on track. I once had to do this twice (maybe a bit impatient the first time).

I’ve had similar things with the ND555 (requiring both analogue and digital power supplies to be powered off and on) and with the Roon Nucleus.

1 Like

Good to know - gradually getting things back - I hope!

…Mr Rooster advice seems to have restored the Melco - it is playing ‘Year of the Cat’ nicely now.

Not yet reinstated the ER - like to isolate what is causing what problem before diving-in.

Ot was accidentally pulling the power from the ER that may have caused the issue.


1 Like

…definitely the ER not working - will give it a ‘rest’ power-down and try later.

Is it lightning? If the network is passing through, the button is clicking ( not continuously unlighted) . The button near the port is flashing if network ok.

…initial re-try with ER back in circuit ‘worked’ then lost connection with Naim App and would not re-establish until I remove ER switch and use the Cisco - then it all works with Melco as I expect - so far.

I’ll re-try the ER again later and see if I can find what has gone wrong there.


1 Like

So far I’ve not managed to get the ER to work with discovery on the Naim App anymore when I put it back in circuit. Tried turning App off and on and it will only find the ND555 ‘Room’ when the ER is not present.

Strange enough the ER seems to still ‘work’ in tha if I swap the feed to have it in circuit feeding Melco and ND555 these remain working and I hear the SQ lift - but then the Naim App loses connection after a short while and it will not work.

…So my original problem was not so much the Melco but that the ER going off upset the Melco - I then fiddled with it and made it worse - and now it is all working again, but the system will not allow sync to the Naim App with the ER between it and the ND555!

Thanks for the suggestions - it did prompt me along to at least get things partially restored and I have music again. :bear:


Hi there!

So you restarted the Melco and ER. Have you tried restarting the ND555 (analogue and digital) after a short power down with the others all connected up?

I didn’t understood well: you said it’s working again but without the ER or finally all is working now?

Yes - that is how it is now.
Just need to fix why the ER is not working right.


I thought I’d done all that - but will try again now and report back!

…report back: no does not fix it.

Restarted ND555 with it in circuit with ER - App cannot find it. Re-stat App still cannot find room.
swap feed to Cisco switch from ER = all works ok.

Not sure what may be wrong - it was all working fine all year since I had the ER until I accidentally turned it off via power lead to its PSU this morning.



The ER lights-up and shows the traffic wibble light so seems to work - apart from the mediating the protocols through it to allow the Naim App on one side of the switch to see the ND555 on the other.

…now that could be something else - at some point next I’ll do the iPad pending iOS software update and re-boot the tablet to see if that is a problem, but re-starting the App usually fixes that sort of problem.

I think I need the fuse! :bear: :hear_no_evil:


1 Like