Mu-so 2 system failure after reset

Recently I had to reset my new Mu-so 2nd gen(not the first time). It flashed yellow for a few seconds and turned off. From then it just gives a single red blink every time it is connected to power. I also tried powering it on with reset button pressed. It blinks red 2 then 4 then 10 times in a loop. If a USB is plugged during boot LED flashes yellow and turns blue(expects firmware sideload?). Sadly I cannot reach out to the seller as I have moved to another country where finding any kind of qualified technical support is almost impossible. Any help would be greatly appreciated.

1 Like

Welcome to the forum. I would turn your muso off unplug it and wait 15 minutes before reconnecting. See if it restarts. There are online support pages.

You could try a factory reset.

But it is worth contacting
Especially if when you restart you get the repeated sequence of flashing red lights.

Thanks for your suggestion. That was the first thing I tried but it seams they are kind of busy right now and their answer will be delayed.

How long are holding the reset pin for? Try holding it longer.

Otherwise, yes, unplug it, go and have tea or coffee then plug back in and see if it clears.

Thank you for your quick reply. Did everything as you suggested(30+ min wait, hope the drink was not nesessary)), holded it for 60 seconds. Nothing changed. Still a single red blink on normal power up and 2-4-10 red led cycle on powerup with reset pressed.

OK, probably best await advice from support. If you don’t hear from them within a few days just let me know your ticket number and I’ll email and ask someone to chase it up for you.

Hope Naim Support sort it fo you soon.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.