Mu-So 2nd Gen, how to turn off MuSo default network

When I first setup my 2nd Gen Mu-So about 2 years ago, the MuSo initially advertised a default wifi network [in the format of “MuSo.dXXX”, where the last 4 character’s were the MAC address of the MuSo]. This allowed me to use my iPhone to connect to that network and setup the MuSo. Once the MuSo was setup and connected to my home wifi, the default MuSo wifi network no longer advertised itself, never saw it appear again.

My understanding of the purpose of the MuSo’s default network was to enable the ability to easily connect to it, perform setup and configuration, and once setup the MuSo default network is no longer needed and disappears. This is what previlously occurred for me.

Now I notice along with my home wifi network that the MuSo.dXXX wifi network has appeared again.

Not sure when this first started, maybe since the last firmware update :man_shrugging:

My Current Firmware Version is:
Airplay Firmware 366.0
Product Version 4.3.1.6471

I have tried completely resetting the Muso and setup as a fresh install and configured the MuSo.
It is connected via wifi to my home wifi router.
The LED light is solid white colour.

Yet, the MuSo still advertises its own wifi network “MuSo.dXXX”.

Seeking advice please on how to disable the MuSo wifi network. :+1:

As the Naim MuSo default network does not require a password it does concern me from a security perspective that anyone could connect to it. Also may even be able to cast music to it.

According to the manual, it should automatically switch off.
Have you tried connecting it to your network via a wired connection?

1 Like

@robert_h Thank you for the suggestion. I just tried connecting the MuSo to my network via wired connection. The MuSo wifi network instantly disappeared.

While MuSo was wired connection, then went to the MuSo web page on my network and choose my home wifi. Placed the MuSo in standby, then back on.

The MuSo wifi network has appeared again.

Hopefully the MuSo wireless network will stop advertising in the next 30 minutes.

Else, on the weekend I may fully reset the MuSo back to factory settings, and setup again while using a wired connection, then configure for the MuSo to connect to my home WiFi.

Thank you again for your suggestion, appreciated. :+1:

Reset the MuSo, and setup as new.

Unfortunately issue still remains, the MuSo wireless network has not stopped advertising itself.