Mu-so 2nd generation - connection problems with iOS

My two Mu-so have connection problems, in the sense that when I open the Naim App on the iPhone or Ipad the first time I can never find the two devices. The attached screen appears. Then I try again once or twice and finally I can. With the first generation Mu-so everything worked regularly and I didn’t change anything at the wi-fi level. I tried to turn off the router, reset the Mu-so and download the app again but nothing changes.

The new Mu-so work with Wi-Fi 2,4 or 5 ghz?

I don’t think this is the new Muso having problems. It may be because the Naim app has changed and it looks first where it expects to find your Rooms and if they aren’t there you have to ask it to look again.

The simplest way to do this is when you get the messsge in the screen in the screen shot in your post, put your finger 2 or 3 cm from the top of the screen, drag the screen down and let go. The app will refresh the rooms screen.



About WiFi?
The old Mu-so was only 2,4 ghz, and the new?

It’s 802.11ac, which would be both 2.4 GHz and 5 GHz.


1 Like

I guess it’s the app, also have it sometimes with my ND555.

I also found problems with the TIDAL App and Airplay, the Mu-so rooms are not always found and sometimes “disappear” and then come back, as happens with the App Naim. Could it be a firmware issue for the new Mu-so?

Perhaps turn the M2 off and see if your M1 still worked same as it was before adding M2. Are Muso’s, you mobile devices and apps all updated and running latest software? What’s the speed you are getting on your wireless connection. I have been having few issues with wireless speeds in my place and I have experienced same issues. My Qb seems to always come up faster then my other gear and they are all wired.

Now I have problems with the TIDAL App. When I select the device with Airplay I find both Mu-so, I select one or the other, I press play but they don’t play. The NAIM App does not immediately find the Mu-so, but then it works regularly, even if it sometimes crashes. I hope they get a firmware update soon, so it’s pretty frustrating.

This sounds like an issue with your WiFi rather than with the apps or the muso 2 firmware.

I suggest you turn everything off, restart the router and then when it has finished restarting, turn the muso on again. Hopefully this will fix the issue. You could also try connecting the muso to the router by an ethernet cable, even just temporarily. They don’t cost much to buy and it will help in finding what the problem is caused by.



Slightly OT but i have mine connected via ethernet and have turned off wifi on both Musos.

I will try, but I think the problem is differente, because with my two old Mu-so I had no problems, and WiFi is the same.

Did you have problems with wifi?

The amazing thing is that I realized now that if I use the TIDAL App with iPad it works, if I use the TIDAL App from the iPhone the Mu-so don’t play :joy:

Sorry Tony, completely missed this.

No, no problems with WIFI, but as i have ethernet everywhere i never bothered with it.

And in all honesty, the Naim app, and some firmware is very flaky.

I keep renaming my rooms and for some reason, it occasionally drops back to the previous saved name, and yes, the app will sometimes struggle to find the rooms.

Naim will generally always say it’s a network problem, even though it all worked perfectly before the updates.

1 Like

I have been having issues connecting the Mu-so 2nd gen via bluetooth with both my Sony Hi-Res players and also connecting the Sony or ipod classic and Ipod nano to the USB. I never had issues with the original Mu-so. I’ve verified with the app that the usb and bluetooth are both turned on. Any suggestions?

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.