Mu-so & mu-so Qb cannot be found in app

Hi,

First time using this forum so apologise in advance if doing so incorrectly.

I have bought a mu-so gen 1 and a mu-so qb gen 1. I manage to set up units so that they are connected to wifi, and add them via bluetooth.

However, I do not manage to add them in the naim app. I get to the last stage of pairing and then the naim app shows an error message. In other words, I manage to see and connect the unit to wifi via app but when doing the final step something happens. I have updated to latest ios and am using an iphone xr. I have tried a 5s as well but with same result.

I did factory reset both units from the start.

Wifi connection is great in hse.
Units are connected via wifi
Internet radio works

Any suggestions? This is so frustrating as I bought these units because I wanted to get a multiroom setup :confused:

Below you can see screendump from app.

Welcome! I’m sure we can sort out your problem.

If you already have the muso and Qb connected properly to WiFi, then you don’t need to do it again in the app. The app will just find them. You tap “Find my rooms” instead of “set up new product”.

But how did you connect them to WiFi? And are you sure your phone is on the same WiFi network?

Best

David

Hi David,

Thank you so much for your fast reply.

All devices are on same network, error messages added above are from when I try to find my rooms.

See all steps below

image image

My understanding is that this setup screen only works for the current Mk2 Musos, although it doesn’t tell you that. So if the app will not discover them automatically, you may need to use the ‘set up manually by IP address’ option.

Ah, interesting! I will try that!

Not sure how that would be different though as wifi for speaker works, it is only the app that seams to be poorly developed.

Will report back

The app is saying that your devices are already connected to a network. So how did you do that?

If they are already connected to a network then you don’t need to do it a second time in the app. In fact you can’t.

How did you set up the WiFi in the muso and Qb?

I don’t agree with Chris’s suggestion of adding the IP address manually. You really don’t need to do that! Even if you get it working that way, it will likely go wrong later. The app discovery is automatic for first gen muso and Qb.

Best

David

Have you contacted Naim Support for help here?

If not, I’d do so very soon because we’re nearing their Christmas and New Year break.

I agree that adding them manually is a last resort, but it might get them up and running for now. When the lease runs out and a new IP address is allocated, that seems to be when the problems start.
I presume that as iRadio works, they are working via the remote control or buttons, and only the app is unable to discover them.
EDIT: I just noticed the screen that says they are already connected! That suggests that the home network config is the problem. Perhaps there are two separate WAPs, maybe on separate SSIDs or something.

To aid understanding, let me explain what the Naim app does.

  1. It allows you set up new products, both generations of muso and Qb, Atom etc and new generation ND* streamers. All the legacy products are set up another way.
  2. It finds automatically any product that has been set up and displays it as a room. There is no pairing of the app involved, or anything like that.

Normally when you get a muso or Qb, you use the app to set up the connection to WiFi. You can’t set that up a second time, which is what you seem to be trying to do.

When you start the app from scratch you get a screen that has options of “setup a new product” and “find my rooms”. If you have already set up the muso and Qb then you don’t tap “setup a new product”, you must tap “find my rooms”. If the muso and the phone are on the same network, the app will now find the rooms and display them.

If you are using the IOS app you can always ask the app to look again by pulling down and releasing the rooms screen, like you pull down and release the email screen in mail to ask it to look for new email.

The problem with adding a room by a fixed IP address is that if your router changes the IP address allocated to that room, the phone won’t find the room. The fix for that is to fix the IP address in the router but this is completely unnecessary and unless you know what you are doing is potentially fraught.

Anyway, talking to Naim support as Richard suggests is a good idea. But if it were me, I would turn one off, reset the remaining one to factory settings and then go directly to setting it up in the app. Then do the other device once the first is working. Don’t pair the muso or Qb to WiFi without using the Naim app.

Best

David

I can go through the setup untill last step. Everything works until app tries to add them as a room

I did IP setup manually. Worked and then it did not so back to square 1

Network setup looks like this. The devices are the ones starting with EC8. All devices and iphone are connected to the 2,4 g

The setup won’t work because your muso and Qb are already connected to your WiFi.

That is why I suggest turn one of them off, then reset the other one to factory settings and then set it up again in the app as if it had just come out of the box.

Best

David

Ok, I Did ip setup manually, did not work so deleted them in app, updated the firmware on router, restarted everything and now everything is magically working. Do not ask me what happened but I am happy. Thanks a million and merry Christmas

2 Likes

Oh well, very good. Merry Christmas to you too!
Best

David

I had connectivity issues with my MusoQb2, when first trying to connect it in via a 5gHz WiFi Network. Once Indisabled this and ensured that only the 2.4gHz network was active it connected first time.

I also had setup challenges with my previous Qb1. I resolved this by doing a factory reset and putting the Muso close to the router providing the WiFi signal.

Both units since worked very well with Naim multiroom from an ND5X2; I have now switched to roon which is the main reason I bought the Qb2.

Both Qb1 and Qb2 are great products, and Naim Muso support were great in helping me resolve issues.

DEAR MR. KOCH,

TOPIC: “NO ROOMS FOUND” - even when Muso is connected and white led next to pinhole

I went almost exactly thru the experience you describe. After numerous attempts at resetting, and calling Naim support 2 times (very helpful, but did not resolve) I was about to set up my Muso as a wired device. Pretty unacceptable for a wireless speaker set… however, when wired to my router using an ethernet cable, both the wired and the wireless connection worked. As soon as I disconnect wired, the wifi also failed.

The Muso showed the white light near the pin hole and therefore was connected to my network but no room found all the time persistendly.

As a last resort I went thru ALL settings in my router (Netgear Nighthawk 750 flashed with DD-WRT firmware). The world changed as soon as I enabled “IPv6”. The Muso worked without fail and was found in the app.
This IPv6 may be obvious to network specialists and other tech folk but none of my other networked devices experienced any problems before (nor after the change), and no-where did I find this as an issue or solution. Hence posting to this forum.

I choose the following options:
Native IPv6 from ISP
Prefix length: 64
MTU: 1452
Dhcp6c custom:Disable
Dhcp6s: Disable
Radvd:Enable
Radvd custom:Disable

That’s slightly odd, as Naim devices do not support ipv6. Perhaps it was the comms with the control device or router that started to work properly when you enabled it.

Thanks for your reaction. I used an iPhone X and also tried and iPad Pro 9.7 inch.
The solution is repeatable.
Could be unique to my set-up (although that seems somewhat hard to believe also):

Netgear Nighthawk router w. DD-WRT (build 40559)
iPhone as above with latest IOS 13.3
Naim Muso (firmware was 1.6 when I tested; now updated to 1.8.0)

My advice to test this if problems are experienced as described in this thread stands.
Would be good if others who find this post reply if this works for them.

With regards,

Are you sure the Muso was working over WiFi? When an Ethernet cable is connected, Naim streamers normally use it by default instead of wireless.

Hello Chris,

Yes I had to specifically switch to wifi - the default is indeed wired.

With regards
Piet

Hello,

Very interesting comment. I have not tried this but I did the following.

  1. Added my mu-so and qb using IP
  2. Entered my router Asus 4g AC55U and locked the IP assigned to these 2 devices

Now everything works but I cannot find the airplay for the units.

Issue that remains is that multi-room function disappear after 24 hrs. What I mean is that when in the naim app the multi-room function to bottom right is gone the next day. I have no clue why but if i restart my router it is there again.

I might have a look today and see if your solution might be better.

Br,
Sebastian

1 Like