Mu-so NAS FLAC Issue

I have just bought the mu-so 2nd gen and I am having a problem streaming my FLAC files from my NAS (Synology DS413j). I have enabled the media server app on the NAS and I can see all the albums and tracks, if fact they all play. However they show up as MP3 files when playing not FLAC.

If I put some FLAC files on a USB drive and play those, they are shown as FLAC.

Is the NAS transcoding these on the fly, I have looked everywhere but the only option that looks like it might do that is not enabled.

Any thoughts would be greatly appreciated.

Open media server app and disable audio transcode. This should fix your problem.

The only option for transcode is to enable it and that box isn’t ticked.

Strange :thinking:
I played a flac file on my NDX2 from a Synology NAS with audio transcode disabled

Then I enabled the audio transcode and played another flac file As you can see the Naim app shows the correct file format.
Maybe a simple restart of your Mu-so or Nas will solve the problem.

It looks to me that the downsample option is enabled (the box appears grey unlike the others which are clear). So I would try ticking the “enable audio transcoding “ option, then untick the downsample option, then untick “enable audio transcoding” once more.

Thanks for the replies.

So after multiple reboots and re-installs the correct icon has now appear on my PC and in the naim app.


So I am now looking in the right place now, however there are no music files when I click on the icon.
I have added my music folder to be indexed and moved a FLAC folder into the music folder that Media Server created on my NAS, still no file are visable.

The indexing says it is running and the NAS CPU is running near 100%, so is it just a case of waiting or is there anything else I can check.

Thanks for help so far…

Looks like a folder permission problem.In Synology go to control panel than shared folders. Open music and verify in the permissions pane if your account has the read/ write box checked.

Right, I think I may have found the problem or at least a solution.

I enabled DMA compatibility MIME for MP3 and FLAC, and files started appearing on the Mu-so.

It is still loading them, but they are there and are playing in FLAC :slight_smile:

That just leaves a conversion process running on the NAS that seems to be getting nowhere, but that’s a problem for another day.

Cheers Peppo62 for your help.

I’m glad you solved the problem. Cheers

Depending on the amount of music you have moved the indexing can take AGES!!

About 20,000 tracks.

Although i think the main slow down might have been my photo library which probably has around 100,000 images in it. I unticked the box to stop these being indexed and the conversion finished in a few hours.

Just re-ticked the photo and video box and left it running, will see how far it’s got in the morning.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.