Mu-So Qb 2 and Netgear Orbi issue

I yesterday upgraded my Wifi network. I replaced the google wifi mesh system with (what is considered top of the prosumer line) Netgear Orbi Wifi 6 (RBK852) system. As I got a new wifi name and all, I did a factory reset on the Qb in order to connect with the new network. When I try to connect via the iOS app the installation get stuck in the setup process while trying to share wifi network details from phone. This has never been an issue in the past, so I suspect it to be some compatibility issue with the Orbi and the Naim device. I have tried to look in the forum here, but no good answer that has helped me so far.

Wired connection is not an option at this stage. I have tried with a cable temporarily, but as soon as I remove the cable I loose the connection of course.

Any ideas?

Might it be easier to keep the same Wi-fi name and password

Is the Orbi mesh running its own network or is it extending the network run by your ISP supplied router (running in bridge mode?) The latter is usually preferable, and if not used, you can end up causing confusion by effectively running two networks. Make sure that WiFi us disabled on your router so that all devices are on the same wireless network.
Once you have made any changes or additions to your network, always restart the router.

Bridge mode in the Orbi is called AP mode, which is what I did to mine

1 Like

Check you’ve given the Naim iOS app permission to discover devices on your local network, it’s a recent security change in iOS.
As others have pointed out, Orbi Router can act as either a router or a bridge to an existing router (the one from your ISP that’s also a modem for example)

I have tried both access point mode and router mode. No difference. iOS app has access to discover network devices.

I suspect it has something to do with Orbi broadcasting both 2.4GHz and 5GHz over the same SSID (and no way to change this in the router settings…). I have read other threads here talking about that but didn’t find a good conclusion or anything that has done the trick for me.

Wired to the router everything works like a charm.

My Orbi works fine, although I have my Naim streamer connected to the Router like you tried, and all the connecting devices on WiFi 2.4GHz and 5GHz. When in AP mode, the router will do all the DHCP network addressing, so I wonder if your router isn’t updating its router table with the WiFi connected Mu-So. Perhaps power off the router and Orbi, leave for 10 mins, then power back on again, then leave 30 mins, then login to your router and Orbi to check the streamer has the same IP address, then retest

I had the same problem, and there were some posts on the topic in response to my question. The explanation I received is that the Orbi treats the 2.4 ghz band and 5 ghz band as a single network with the Orbi deciding which to use for each connected item. But if your phone is on 2.4 and the Mu-So is on 5.0, the phone won’t see the Mu-So (or maybe it’s vice versa). My problem went away after I used a cable for set-up. I could then remove the cable and the connection remained. I gathered from the posts that others were not so lucky.

That’s the layman’s explanation of the problem. I was new to Naim at the time, so I did not phrase my questions as well as you did. The first thing I would recommend is going into the Orbi Admin app and checking to see if phone and Mu-So are on different bands.

Edit - here is a link to the thread I started in January.

I have an Orbi (not the latest Wi-Fi 6 version but still tri-band). I don’t have any issues with either my Star or Qb (1st gen). The Orbi just has one SSID for both bands. The Star connects to the 5GHz band and the Qb to the 2.4GHz band. I have no issues discovering or streaming to either, including linking to playback the same music on both.
The Orbi would need to be set to AP mode if linking to another router and the Wi-Fi in the existing router should be turned off.

Here’s one of the threads I ran across.

(Look at the post above this one.)

Looks like the problems may be specific to the 2 series.

I have been running a MuSo2 since November 2019 and the only time I had an issue was when I moved in February last year and the Sky hub had to be placed near the front door where the master socket was located. This was the worst place in the property and although the MuSo2 was wired and the iPhone showed 2 bars of wifi, I had discovery issues and an app that was inconsistent. I moved the Sky router to a more central location and since then it has been back to rock solid.
When there is a network without issues in place both the MuSo2 and the app work without problem.

1 Like

Nevertheless, not only the OP and I, but others have had difficulty with MuSo 2 series units and routers which treat 2.4 Ghz and 5.0 Ghz as a single network.

I was fortunate; my problem vanished after I got through setup using a cable. Both my Mu0So and iPhone are use 5.0 Ghz. And after reconfiguring my set-up (for an unrelated reason) my Mu-So has a permanent Ethernet connection.

An update on the latest status on my headache here:

  • I have finally managed (one time) to connect via WiFi to the Muso Qb 2. It seems as if doing it via the app was the worst option. In the manual (RTFM!) there were two or three other options to connect except via the app
  • When I finally connected I saw a strange behavior on the light on the back. It constantly switches between solid white and solid purple (see video below)
  • When I investigate in the Netgear Orbi interface, I can see that the speaker swaps between 5GHz and 2.4GHz. I guess this is the root cause to the issue
  • After a while the Speaker settled to 2.4 GHz and then it worked.
  • After moving the speaker to the intended position in my house, the problem is back and light indicator is switching between solid white and solid purple

Nb: I used Google Wifi mesh before, also automatic switching between 5 and 2.4 GHz, without any issue at all.


Two thoughts:

Do you have a second device that can run the app and connect better to the Mu-So?

Second - $$$ - get an additional Orbi Satellite and place it near the Mu-So so you can connect by Ethernet.

I don’t know if returning/exchanging either device is an option.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.