Mu-so Qb can't connect to wireless network

I have had a Mu-so Qb 1st Gen in our home for several years. It is connected to our wifi network and is used as an AirPlay speaker. Last week, the Mu-so was not listed as an available speaker in the Music app on our Mac or in any of our iOS devices. We also use it conjunction with a Mac program called Airfoil and it was also not listed there. The rest of our Airplay-compatible devices (AppleTVs and a HomePod mini) all show up in the list of available speakers.

The first thing I attempted was to unplug and replug in the Qb. After waiting a few minutes, it still did not show up as a speaker. I tried a few more times with no different results. I then did a reset by holding in the reset button for six seconds and waited until the light began to flash purple. Once I did that, I used the Naim iOS app to find the speaker. The app found the speaker and then it began the AirPlay Setup. It attempts to connect to the wireless network but after a few minutes, the AirPlay Setup window displays a message stating “An unexpected error occurred. Try again.” But trying again results in the same error message. I also tried to add the speaker directly in iOS. I can see the speaker in the Wifi section of Settings. I select the speaker and the AirPlay Setup begins and again attempts to make the connection but fails with the same error as above.

I haven’t made any recent changes to our wireless network other than a firmware update to our router. Our wireless equipment consists of a Unifi Dream Machine router that has a built-in access point and one Unifi AP-AC Pro access point to extend coverage. Unfortunately, the Qb is located in an area without Ethernet, otherwise I would connect it via hardwire.

Are there any suggestions on what else I should try or ideas as to what might be causing the issue?

Thanks in advance.


Sounds similar to a problem I’m having with a QB. Do you have an android device you can try/borrow - can it see the QB ?

If not, try rebooting the router which worked for me. This isn’t a fix, but a work around, if you end up doing it too often your line speed will be reduced. I’ll list my issue in full when I’ve thought about it a bit more. (It”s not a BT Smart hub 2 is it ?)

As a follow-up, I have resolved the issue. I have three networks in my environment - the main network, an IOT network and a Guest network. There is a corresponding wifi network for each. I was trying to connect the Qb to the main network where it has always been used but was now failing to connect. In doing testing, I decided to try connecting the Qb to the other two networks. In both cases, the Qb connected as expected. So this led me to believe there was some setting that was different between the networks.

While looking at all the settings on my UDM I found that the main network had an advanced setting called Group Rekey Interval disabled but it was turned on for both the IOT and Guest network with it set to 3600 seconds. For testing, I turned Group Rekey Interval on and set it to 3600 seconds and I was able to immediately add the AirPlay speaker. I never changed that setting (I didn’t even know it existed) but somehow it was turned off.

Now all AirPlay speakers are working as expected.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.