Mu-so QB won’t stream Apple Music

Hi everyone,

System
Naim QB Mu-so 1 Firmware: v2.0
iPhone X: iOS 15.1
iPad Pro 3: iPadOS 15.1
Router: Ubiquity AmpliFi Alien WiFi 6 Mesh Router. (I have only one router).

My Muso QB (1) wont play from Apple Music. It is however successfully added to list of speakers in the Apple Music app.

Basically, this is what happen: I choose QB Mu-so (1) from the list of speakers, and press play in the Apple Music app. Then no sound. 5-8 seconds later Apple Music switches back to the Iphone X.

This also happened on my iPad pro 3. Its like it just won’t stream to my QB Muso 1. However it remains on list as an available speaker.

I know the QB Muso (1) is a 2,4ghz and that and my AmpliFi Alien router is supposed to fix this automatically. I did try using a dedicated 2,4 network for the QB muso 1, but same thing happens. All other IoT’s in my home (20+ IoT’s) works perfectly, even the ones that only work on 2,4ghz. The network signal is strong. Qb Muso 1 is listed in the IoT list in the AmpliFi Alien app. Funny thing is that I can stream radio from the NAIM app.

I don’t know if this is an issue with Apple Music or if the speaker is no longer compatible. Or maybe some kind of security issue? I have gone through reboots, deleting and reinstalling Naim app, and the thing with setting up a dedicated 2,4ghz network. Nothing works. For the moment my QB Mu-so 1 is only a Bluetooth speaker.

Any solutions?

Hello and welcome to the Forums.

Something’s obviously not quite right with the AirPlay 2 functionality here. Sure we can get you sorted.

You mention reboots, but have you done a full pinhole reset of your Qb?

  • Turn Mu-so on using the touch screen rotary dial or remote.

    1. Using the Mu-so pin-hole tool, press and hold the pin-hole button for six seconds to reset Mu-so defaults.
    1. The touch screen rotary dial outer ring and light bar will illuminate and pulse indicating the reset is in progress.
    1. After a short wait Mu-so will return to standby mode.

My Muso QB1 will stream Apple music from my ageing iPad and MacBook (with current iOS) so you should be optimistic that there is a fix to be found.

Yes, I stream Apple Music to my Qb1 no problem, so there’s definitely no platform issue.

This may be an issue with your local network or router. I had a similar issue in the past with Marantz system that had AirPlay. It turned out an old WD NAS on the network was running an old version of some DLNA media software. Once I disabled the media software on the NAS the issue was resolved, so check all the devices on your network!
Also ensure your router firmware is up to date, and give it a re-boot.

1 Like

Yes, I have tried this to, did not fix. But thanks:)
Muso WB 1 gen is only AirPlay 1, is it not?

Firmware on AmpliFi Alien router is up to date. And the other you are mentioning, I am not that technical, must look into it though.

MuSo QB first generation supports Airplay 2. You may need to update the firmware to get this but it has been supported for some time.

My Naim QB Mu-so 1 have the latest Firmware: v2.0. Is there anything else i need to update?

Check your Apple devices are running version 5.22.2 of Naim App

The Airplay issue is not likely to be related to an App problem, but will be down to some issue with the local network. For trouble shooting try using a wired LAN connection to the Qb to see if this helps. Maybe an issue with the router not passing all traffic over between 2.4GHz and 5GHz networks.

It does, app on both iPhone and iPad Pro is latest versjon.

Yes I am optimistisk:) :blush:

:+1:t2:

Firmware is 2.0v in this Naim QB1. So should be fine.

Just tried cabled Network. Same thing happens.

Have you tried starting the track playing and only then selecting the Mu-so from the AirPlay list?

Hi Clair,
Is there a way to reset my Muso QB1 to the previous v1.7 8 (or something)? Just want to try that .
Annyhow, am thinking this is a network issue….:thinking:

What troubles me is that same thing happens now that I have set a Network cable from my Alien router to the Muso QB 1, and same thing happens🤷‍♂️

This does seem very odd and I don’t think reverting to the previous version of the software on the Muso will make any difference.

I did have a problem with the Muso connecting to the WiFi and the internet when I was using a range extender - Apple Express. The problem seemed to be that sometimes the Muso switched from the main WiFi source - Apple Extreme to the Express and connections were lost. I say this because I think that your problem does lie in some oddity in the WiFi set up and some disparity between the iPhone/iPad WiFi connection and the Muso. I presume this could be happening even with the Muso connected directly to the router if the app is connected to a different element of the wifi. However, my technical expertise is very limited. The person on the forum who might be able to help - and he has commented on mesh WiFi before - is Simon-in-Suffolk, so attracting his attention might be an option.
Good luck!

Hi @JonasHusabo

Try switching off ‘private address’ in the ios settings->wifi->press ‘info’ indicator next to the network.

Once done restart the ios device and see if it then works.

Best wishes

Steve Harris
Software Director
Naim Audio Ltd.