Mu-so Qb1 and Asus Mesh WiFi Problem

I have recently installed a mesh WiFi using an Asus ZenWiFi AX mini. This has significantly improved the WiFi coverage and stability in my 3 storey townhouse and garden. All my exisiting equipment has been fine except my version 1 Mu-so Qb which is no longer able to connect to internet radio or AirPlay. I can still use the Mu-so Qb1 with Bluetooth and UPnP. Internet radio will occasionally connect for a few minutes but then loses the connection.

The mesh WiFi is connected to my BT Home Hub in access point mode so the Asus ZenWiFi base station and its nodes distribute IP addresses. As advised in the instructions for mesh WiFi, I turned off the WiFi channels on the BT Home Hub.

The Mu-so Qb is running the latest software and firmware. I had it connected to the WiFi channels on the BT Home Hub for several years without any issues. Neither a hard re-set of the Mu-so Qb1 nor allocating it a fixed IP address has solved the problems. It is not feasible to run the Mu-so Qb1 with a wired internet connection (it is in the kitchen and the router and Zen WiFi are in a different room).

My version 1 Cambridge Audio CXN streamer connects to the mesh WiFi without any problem giving internet radio and AirPlay.

Searching the forum, there was a post last year from somebody having problems connecting their v1 Qb to a mesh network. My only solution appears to be to restart one of the BT Home Hub WiFi channels and connect the Mu-so Qb to that. Although that runs the risk of adversely affecting the mesh network.

Does anybody have another suggestion?

Could you perhaps put one of the Asus modules in the kitchen and then run ethernet from that to the Qb? We did something similar for my Dad running a cable from a BT disc to an Atom and it worked very well

When you say upnp are you referring to playing music from a nas or computer? If so, the wireless connection between the ASUS and the Qb must be sufficiently strong with the modules where they are at the moment. Is the Qb your only Naim? Can it receive high res files via upnp ok?

We have a Zen two box system. Our Virgin hub is in modem mode so that the ASUS does everything else. I wonder if the BT thing is causing some sort of conflict.

The UPnP is streaming FLAC files from my Synology NAS. So, yes, the WiFi connection is clearly good enough for that. That is why I cannot fathom why the internet radio and AirPlay don’t work. Must be an internal issue with the Mu-so Qb v1.
Thanks JonathanH for the suggestion of wired ethernet from one of the Asus nodes - I’ll try that and see what happens. It would mean buying another node (about £100) because I need them on the 1st and 2nd floors to cover the house.

In Access Point mode I would expect the DHCP server to remain with your BT router and not on the mesh system which would normally only be a DHCP server if set to be a router. If you are running 2 DHCP servers you could be in for trouble and could have 2 address ranges running which would give unpredictable results and could affect your routing out to the internet if the address is assigned by the ‘wrong’ server.

I use the TP Link mesh system in Access Point mode and have no issues with my QB’s Mk1 of which 2 are wireless and one is wired.

That’s what I was thinking but as ever you explain it so much better. It seems to me that both of the ASUS boxes should be in access point mode, so that the BT box does the DHCP.

I wonder if it’s possible to use the BT box just as a modem, as I do with the Virgin Hub. Either way it’s essential that there is only one network. Hopefully this will fix it at no expense. I’m not sure adding another Zen box would achieve anything, given that the Qb has sufficient wifi signal to run upnp.

Thanks JonathanH. Using one of the Asus nodes and hard wiring the Mu-so Qb via ethernet has restored all the functions.
I don’t really understand the reasons for the problem when UPnP streaming continued to work. Interesting that the TP Link mesh works in wireless mode. Clearly an issue between Asus mesh wireless and Qb Mark 1.

I’m glad it helped, that way of doing things seems to give pretty robust results

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.