Mu-So Qb2 Installation Asking About Rooms


Just got my Mu-So Qb2. Although, I’ve been an audiophile for almost 50 years, this is my first Naim purchase.

I had some problems with the installation, and although I seem to have stumbled through them, I have questions, especially as my experience is that all Wi-Fi products need a reset now and then.

The installation was moving along until the iOS app started searching for rooms but couldn’t find any. First, why would it ask about rooms? Why would it expect me to have rooms? I do have rooms in connection with my Google Nest/ChromeCast products, but I can’t see how that is relevant.

I do have a mesh router - a Netgear Orbi with one satellite. I connected the Mu-So and the router by ethernet and after some stumbling found that it was working even without discovering rooms. It continued to work after I switched the connection back to Wi-Fi.

One thing I noted is that installation referred to AirPlay 2. I do not use AirPlay.

Can anyone explain what was going onon?

Naim has a multi-room feature because you may have a Qb in the bedroom and a Muso in the kitchen and a streamer in a living room system. Each is a “Room” and you can control them all from the app. See and search for “multiroom”.

I don’t know what it asked about Airplay but it supports Airplay, so maybe it wanted to ask something about it, or tell you something. Seems reasonable

“Room” is simply a synonym for “device”, but I guess might not be obvious to the uninitiated. If you have an iphone then airplay is the natural connection and fully supported by the mu-so and qb 2nd gen.

Then, robert_h, reading between the lines, the message meant that the iOS app couldn’t find the Mu-So, itself, until I connected it to the router via Ethernet. Not sure why that should be the case, but it makes sense.

There was a warning about issues with mesh routers.

Thanks. I understand that. (I’ve had multiple Squeezeboxes for a decade. :smiley:) I just don’t understand why it would search for them during installation and not permit me to complete installation when it failed to find any (or in my case until I made an Ethernet connection. Even after that it kept searching for rooms (as far as I can remember) until all of a sudden the app proper opened up.

I may still be misunderstanding you, but I don’t understand why and how it would continue with configuration as long as it did not find a room. No room, no device to configure.

My best guess is that it worked whilst connected by ethernet, you then moved the Muso to a different location where it couldn’t connect to the wifi, therefore, the app couldn’t find the Muso.
When the app cannot find any Muso (or other Naim device) it will say it’s “looking for rooms” (or searching for rooms - I forget which).
Many people are using Mesh systems with Naim equipment, so it can work but, the implementation of Mesh systems apparently has to be spot on, with correct parameters to ensure it’s seamless and covers the required wifi area with no wifi holes.

Just to be clear, once the initial connection was made via Ethernet and a little more stumbling around, it worked on Wi-Fi. No further adjustment needed.

As others have said, “searching for rooms” isn’t part of the initial setup. It’s what happens every time you open the app and the app doesn’t find a streamer (a room in Naim speak) where it expected a streamer to be.

It should resolve on its own. But you can hurry it up by dragging the screen down and letting go. If that doesn’t work, swiping the app off and restarting the app usually works.

What you don’t need to do is starting doing factory resets or anything like that!



Thanks to all. Once I learned that “room” was the term used by Naim to indicate one of its units, the nature of the problem made sense.

Their hope being, of course, that you will decide one room is not enough. It’s a clever marketing ploy!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.