Mu-so worked great now not buffering and dropping stream¨

My Mu-so worked great for 1.5 years, Now suddenly it is not buffering the stream reliably and dropping the stream repeatedly. Other devices are ok
What to do?

Has anything recently changed at home network wise?
Reset (power cycle) everything and retest

Thanks for your suggestions- unfortunately the network is unchanged and functioning- my squeezebox touch is streaming without difficulties. I have disconnected the power several times without a change in the problem. Any other suggestions?

Many thanks

@robgr meant power cycle everything including specifically your router. Did you do that? It would also be worth emailing Naim support but be sure to mention where you live as they will know whether they have other reports from that region. Also tell them what you are streaming (iradio or Tidal or Spotify or whatever).

Also is your muso connected by WiFi or ethernet.



Many thanks! I ad not understood so I just powered the router down as well and for the moment the Mu-So is playing (Tidal stream). I had contacted Naim support without a response so the community assistance/support has been crucial-
Thanks again

That’s great. Even if a router is working fine for other products, it may not be responding to the specific protocols that Naim use. So that’s one reason why a router restart is often a solution.

If you still have problems, post again here and one or more of us will try to help.



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.