Hey I have searched the Forums but couldn’t find what I’m looking for. I own a Mu-so 1st gen and stream music via spotify, choosing the speaker as the output. I have no issues with it until recently and it doesn’t connect very easily now. Sometimes I need to push the muso device up to 5 times before it finally plays. I have an Android but have only recently had this problem. All software is up to date and interestingly, my parents also have the same speaker and I can connect instantly with no issues.

Any suggestions?


Try turning it completely off and on again. Or use the reset button at the back.

if that didn’t work i would unplug muso then turn off router wait 5 mind turn on router wait for it to cycle then turn on muso - it has worked for me

Unfortunately neither of the suggestions worked. The Muso does switch on after a few seconds after I initially click on it through Spotify but then the output switches back to my phone. It does take 4 or 5 attempts until the Muso finally plays.

My early first gen muso had developed some odd habits… 1) it turns its self on and plays - not helpful at 3am! 2) if I play an album it will play one song and then stop.

I guess nothing lasts for ever but disappointing none the less. It’s not really worth sending it back to HQ as its value is probably sub £400 these days so not en economical repair.


Edited to remove incorrect comment thanks

Naim operate full repairs on musos in the factory.


other things to try - restart phone and downloading app again

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.