Muso 2 not working and no support


My Mu-So 2 stopped working after about 6 months. I’ve tried wifi, bluetooth, usb, lan. At most I get 1 second of sound, and then the dial ring lights up permanently, the orange LED flashes, and its unresponsive.

I’ve tried contact support a few time via email - but all I get is an automated acknowledgement (poor show). So I thought I’d try here if.


Hi Niall, sorry to hear that - how long ago did you try to email support? Have you tried phoning them?

If you let me have your ticket number I can email Naim to make some enquiries for you.

As for the Mu-So, have you tried a full reset?

Also I’m not sure whether “” is still valid; best use simply “support@“. Every new email makes a ticket in freshdesk so can easily be tracked with admin access. Mu-so support is 100% in-house so you should get a response from Duncan etc.

Hi - yes I’ve email them ( a few times over last 2 weeks. I’ve gotten two automated ticket numbers from them 82120 and 82940. I’ve not tried calling yet just as I’m on the other side of the planet.

Yes I’ve tried a couple of hard resets using the pin hole on the side. Unfortunately same symptoms.

I’ve reached out to local reseller also to see if they can support.

OK thanks Niall. I’ll pass this on.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.