MuSo 2 WiFi problems


Thanks Steve for the leads and for the offer to take this offline. The 2.4 GHz has not been problematic for me and I also have a wired option I can use so there is no pressing issue. This is just one of those times that I’m stumped and determined to figure it out. Time permitting!

I think the disconnect issues I had were related to the “smart” connect feature on the Synology router which I have now turned off.

I know for sure that I do NOT have any MAC filters turned on. I know for sure I have devices connecting at 5 GHz. I know my router is set up to connect on the 802.11ac standard.

However, based on your comment …

When the Naim app does the setup, it is typically the phone OS that enumerates the wifi access points out there. It indicates they’re all handling this tricky 5GHz feed differently.

The Android phone that I am running the Naim app on does NOT have a 5 GHz radio and that very likely is the reason when I use the Naim app it does not show the 5G SSID.

I still do not understand why the connect does not work to the 5 GHz network when I attempt to connect via the product web page.

Well guess what? My Muso-2 has disconnected itself yet again from my wireless network. You can read the history in my previous posts in this thread. I’m done with the Muso-2 on wireless. It’s just not worth my time and effort. Powered if off, powered back on; still will not re-connect. It’s forcing me again to go back to the setup routine via the Naim app. I have the option to go back to wired but that’s not the point. The Muso-2 is sold as a wireless streaming device. I have a 10 year old SqueezeBox Radio that performs better on a wireless connection! Really! It costs a tiny fraction of the price of a Muso-2.

The Muso-2 when playing music is a fantastic sounding device. However I will not recommend it to friends and family until Niam can deliver a device that is trustworthy on a wireless connection. And can you imagine how frustrating this would be to a non tech savvy person?

@Stevesky Thank you for trying to help on this issue. I believe this issue is now something that Naim needs to explore, test and address. I’m not the only one having wireless problems. And like I’ve mentioned previously; the Muso-2 is the only device I own that is experiencing wifi problems.

Back to enjoying the music …

1 Like


Hi, do you have an update on your Muso-2 wireless issues? After I saw your initial post I decided to give wireless a go again after having issues when I first set up my Muso-2 several months ago. On this second attempt at wireless, I had issues again. They are documented in this thread. I’m tempted to report this to Naim as a support issue but since I have a wired option in my home I am not sure it is worth my time and effort. If I only had a wireless option I’d be pretty upset and would for sure open a support ticket.


For the [quote=“VikasMG, post:1, topic:6171, full:true”]
When I did a search before posting this I saw that this topic showed up some months ago, but there seemed to be no real resolution.

I have a MuSo 2nd Generation and a Qb first generation. The MuSo keeps not being found in Rooms by the app and also won’t show up in the iOS AirPlay list. I have to unplug and restart it to get it to show up but then it drops out after under 30 minutes. The Qb is rock solid. My first generation MuSo was also very stable but unfortunately I gave it away to my son and bought the 2nd gen with these problems! So it can’t be a WiFi issue. The firmware and app are also both up to date.

I am in Washington DC but we also have a home in Singapore where I have a Unity Nova and a MuSo first generation and they are both very stable with their WiFi connections.

Has anyone found a fix to this that I have missed?

last two days the MuSo-2 has been stable and connected to WiFi - and I don’t know what brought this change about. Unfortunately I’m going to be traveling for a while after this weekend so I wont be able to tell if it stays that way. But if I have problems after my return I’ll have to take it up with Naim…

1 Like

Hi All,

Regarding these wifi issues. We’re really keen to unravel these issues - they’re a fringe condition as we have loads of Muso MK2’s out there working fine, but it’s clear there are some installs that are problematic.

As it’s hard to resolve support tickets to forum post names, could you email me with your issue. Give me a detailed list of:

  • Forum name
  • Network kit used Iwifi router, switches, repeaters, etc)
  • Any support tickets numbers raised in the past
  • How the muso/qb is connected (2.4ghz, 5ghz, ethernet)
  • If you use ios or android app and device/model used.

I’ll ensure the necessary people look into it. My email is steve.harris(at)

I know networking related issues can be infuriating to track down, but if the issue is a Naim one (and many times it’s not), we would like to get to the bottom of it and fix it.

Best regards

Steve Harris
Software Director


Thank you Steve for helping out, greatly appreciated and beyond the call of duty.

I wonder if the guys having issues turn off the Wifi on their iPad etc wait 30 seconds then turn it back on return to the Naim app and see if the app finds the rooms…worked for me…not sure why or how!!!

1 Like

@Stevesky Thanks again Steve. I’ll be in touch via emial.

Good to know, thanks

OK, having read all these comments I have reconfigured my BT Home Hub to separate the 2.4GHz and 5GHz frequencies into two networks. Then I set up the ipad mini I intend to use with the Naim app and the mu-so qb so they are the only two devices in my home on the 5Ghz network. No drop outs so far so I’ll see how it goes for a few days.




Good idea, how did you do this?

We are also having problems with our MuSo 2. The Router is a newly supplied ZyXel version. I just want it to work - I don’t want to acquire knowledge of Router GHz and filters to make it connect. I just want to play the 100GB of music that is sitting on my PC on the MuSo 2. My wife’s Samsung phone has a 25% success rate of connecting to the MuSo 2 to act as the controller. And the volume resets itself between tracks. My Sony NW-A45 cannot find the MuSo 2.


The first thing I would do is make sure that your and your wife’s phone are connected to the same WiFi network as the Muso.

One day my wife could not connect to the Muso and we realized that her phone had the Wifi turned off (who knows why). We did not realize it at first because her phone was connecting to the internet via our cellular plan. Once we turned on Wifi, it connected to the Muso.

The other thing to be aware of are the 2.4 Ghz and 5.0 Ghz wifi networks. My router supports both so does the Muso. Your router may be be same. Our phones only support the 2.4 Ghz network, your phones may support both. The phone running the Naim app has to be on the same network as the Muso. Could it be that your phone is on a different network than the Muso and your wife’s phone on the same one as the Muso?

I don’t to want comment on the other issues you are having. As you can see in this thread, I too am still having intermittent issues with the Muso wifi connection.


If you don’t mind sharing; did you ever resolve your Wifi connection issues with the Muso 2?


I’m away from home now so I can’t access the exact steps I took but I used the info on my BT Hub to link to its IP address then login using the admin password on the hub device. Looking through the options I found one that said something like ‘separate frequencies’. When you do that and save the change all your Wi-fi devices show you now have two networks called ABCDE and ABCDE-5. Then I reconnected the iPad and speaker to the new ABCDE-5 network. Hope this helps

1 Like

I have been searching for a forum such as this to express my views on the Mu-so Qb 2nd Gen. Glad to have found it at last.

Almost everything I have seen on this thread echos my own experiences. I managed to pick mine up (Maidenhead, UK) very soon after they were launched. I have to say the aggravation I have had has driven me mad.

Everyone here is being very polite and patient, a good thing , but there comes a point when the manufacturer must kick in and recognise he has a problem and then solve it. I would never recommend this device to anyone else based on my experiences so far.

Brief summary. The wireless router is approx. 2m directly above the Mu so Qb 2nd gen with a timber floor in between. All android and Apple phones work perfectly in this position, as do our laptops, for streaming anything on line. No problems. The wi-fi signal strength is rated at 90% to 100% in this position.

Some mornings I come down and start my phone app, and the Qb shows up immediately, on the phone app, and then starts up. This might happen for 2/3 days on the trot and then the next day - nothing. Completely random. And so it goes on for several days more. I have kept detailed records of what I have done and when and it beggars belief how unreliable it is. Some days I switch it on and off numerous times, and then re-set it, and nothing. Then suddenly 4 hours later it has decided to connect to the wi-fi and starts up!

Of course the phone app cannot find the Qb if the Qb is not connected to the wi-fi, so we cannot even listen to the USB files plugged in the back until the damn thing has decided it wants to connect to the wi-fi network.

I am truly not interested in discussing 2.4GHz or 5GHz issues - as owners this should not be our problem. Clearly the Qb 2nd gen (and it would seem the Mu-so) have an inbuilt problem, otherwise we would not be spending time on this forum. Our router works fine streaming data for TV shows, and all internet related stuff on the wi-fi network. So I don’t accept that the Router might be ‘old’ or out of date. I am not going to take a chance and spend money on a new one that might not solve the problem.

I also have read Naim advice regarding wi-fi extenders. Again what house does not have extenders in use? The Naim product should be capable of connecting regardless of this. The design should be able to work around this situation.

Given how much kit is now capable of being upgraded using firmware, why can Naim not do this to solve these issues?

I challenge anyone at Naim to actually solve my problem! 'When ’ it’s playing music it sounds great, but the frustration of coming down first thing in the morning to complete silence when all I want to do is listen to the news is driving me mad.

I would never buy another Naim product unless they show willing , step up, and solve all the issues listed here.

If ‘Steve’ or anyone else there would like to assist I would be very grateful.




Hello Peter,

Welcome to the forum. Your level of frustration comes through loud and clear on your post. Steve Harris of Naim did finally determined the problem with with my Muso-2 WiFi issue. It was not something that could easily be solved in a short term . It had to do with FCC (US Federal Communication Commision) standards and my particular router. I was lucky because I had a couple of options to set up the Muso on a wired connection. I tried TP Link Powerline adapters and then eventually settled on MoCa adapters (using TV coax wiring for Ethernet). Since I switched to wired I have had zero connection issues.

The Naim WiFi should just work. I’ve got devices that are more than 5 years old that have no problems connecting and staying connected to my network.

Hopefully Steve will reach out to you. Take care and be safe.

1 Like

Appreciate the response Mike.

I am awaiting Naim’s response with baited breath :smile:. Seriously though, despite my frustration, I am willing to talk in a grown up manner provided we can solve the problem. I don’t want to go down your wired route as that option is just not convenient for me. Hope they can solve the wi-fi.

Thanks again.


You might want to bear in mind that this is a discussion forum hosted by Naim. It’s not the formal channel for product support, which is either via your dealer or by phone or email to Naim. They do sometimes pick up on issues mentioned here, but it’s not their official means of tech support.


Was anyone able to find a solution for this problem? I am experiencing the same. I have just bought 2 Qb 2nd generation, 1 Mu-So 2nd generation and Uniti Nova.

I have connection problems with both Qb’s and the Mu-So similar to what is described in this thread. The Uniti works fine for now…

So much money and it does not work…

I have the newest Netgear mesh router.

Thinking about returning it and go with different brand of no solution was found.