Muso bluetooth problem

Hi, I upgraded the firmware on my Muso, and now it won’t connect with my iPod or iPad via bluetooth. I just get the error message that the Muso should be switched on. I’ve gone into the Naim control app and it indicates all is fine, I’ve used the app to clear all previous blue tooth connections, switched the Muso off, but still no luck.
The Muso does appear on the iPod and iPad as a blue tooth connection option, but it just doesn’t connect. Any ideas on what more I could try?
Best wishes Amer

Having followed all the App/software/firmware issues on here for what seems like forever - I don’t use the App or do any software or firmware upgrades. I just listen to the music :grinning:

That’s one solution …

Yup agreed, but unfortunately I have done the latest firmware upgrade that came up and I do use bluetooth a lot to listen to playlists on my iPod and phone, so I would like to get bluetooth working again. Best wishes Amer

Why not just use airplay? of course bluetooth should work but it is power hungry and poor quality compared to airplay. Of course cromecast would be better but that is for the upcoming mmuso 2.

I have just tried on latest firmware and the app beta so very latest everything.Go into settings on the naim app, Select input settings, bluetooth. Ensure use secure bluetooth is disabled. For some reason I had it enabled, something I am sure I have never told it to be. Press drop connection, or maybe it is forget connection I am not sure. Reconnect from your device and it worked for me.

Thanks Clause, I’ve tried what you suggested but it still would not connect. On my iPod it still said connection failed make sure Muso is on. Which it is. Maybe I should try completely resetting the iPod again via my computer. I’ll give that a go.
On your advice to use Airplay, I don’t know how to connect my iPod mini or iPad this way. I did set up the Muso using Airplay to get the radio stations I wanted as I was prompted to do so by the Naim app.
Best wishes Amer

Hi Clause, I’ve just restored my iPod mini back to factory settings and reinstalled the music via my iMac. Bluetooth now works again on the Muso! Thank you so much for your support, your comments encouraged me to try that route, I wouldn’t have done it otherwise.
We’re going away for a few days and I’ll look into how to use Airplay instead when we get back.
Best wishes Amer

1 Like

Hi Clause, Correction, I have a iPod nano 7th gen. A quick query via the Apple help community suggests that it does not support Airplay, but I’ll investigate further when I have more time. Best wishes Amer

Hi amer,
Nice you got it working. Here is a link to how to enable airplay on iOS 12, much more complicated than it should be! You can setup the muso as an airplay2 device and enable it with siri, that is most time it works for me and is much simpler than going this route:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.