MuSo Gen 1 - IRadio, updating firmware, Asset media and Focal/Naim App

I am assisting a colleague updating his MuSo and have a number of issues that I would appreciate help.

The Focal/Naim app is running on a Lenovo android tablet and both the app and MuSo firmware have been updated to the latest versions.

  1. IRadio flac stations - none of the IRadio stations i.e. Radio Paradise are presented as flac. Does the MuSo gen 1 support flac radio?

  2. I cannot get to the radio stations tree as it defaults to Naim choice or jazz etc. without an option to get to the “all stations” and other options? Pressing the IRadio source show the presets from an earlier installation, and some have been updated and are working fine. No option for the tree. What am I missing?

Lossless iRadio is not supported by the 1st gen streamers although there is a workaround from @Kurt that may work if you search for his thread on it.

1 Like

@Paul_C : Have a look here: Native FLAC via iRadio?

1 Like

Thanks for IRadio flac responses. I should have remembered previous topics.

Things went well. The MuSo Gen 1 firmware was updated and all went well. The previous time, pre-pandemic, the MuSo update crashed and had to switch off/switch on/switch off/switch on several times before the MuSo was eventually recovered. The MuSo sounded impressive.

The Focal/Naim app was installed/updated on a recent Lenovo Yoga Android tablet (Android 10). The app appeared sluggish but eventually worked. Strangely an older Acer tablet running on Android 7 worked much quicker on the Focal/Naim app. The Focal/Naim app would not work on an IPad as it required IOS v13 (Naim bad mark for compatibility) when the Android Acer is probably older.

Installed AssetUPnP R7.4 Windows) to replace Servio on the Windows PC with external hard disc holding the media library. AssetUPnP worked flawlessly as expected.

The Focal/Naim app kept losing the “Room” i.e. the MuSo. The Muso is on wired ethernet so the problem appears to be the usual recurring app problem. As an alternative using BubbleUPnP the Muso connection was consistently stable again indicating the App is the issue not the MuSo.

The new Focal/Naim app design seemed crass as the initial screens are unnecessary and why you cannot link to existing Naim devices directly as practically all users will want to do.

The Iradio did not present flac stations (as previously reported) but this is not stated in the Naim MuSo Gen 1 Manual!!!

I did not find the app intuitive particularly navigating the trees for both Asset and IRadio. Locating the IRadio “All Stations” and searching for new stations seemed messy.

Could not see how to access the play Queue and an option to directly play a whole album would be helpful. I am used to a “PlayAlbum” button.

Examining the App settings I found “MultiRoom” was set on. Why, how, new default - I don’t know as there was no multiroom. Turning it off seemed to improve things!

Tried to use playlist from Asset with external radio stations using http and https URLs. These stations consisted of mp3, flac and hi-res flac. They all played for 2 seconds then stopped. These work OK on a Denon streamer from Asset using BubbleUPnP (and also work on Linn Kazoo) so needs to be followed up with Naim. See topic Naim streamers will not play playlists with http and https URLs - Streaming Audio - Naim Audio - Community (Update - Naim have now confirmed this does not work on the Mu-So gen 1 but is supported on recent devices.)

Overall the exercise was a success and my colleague has an updated “nas” with Asset that plays well on the MuSo. The regular lost “Room” app issue was and remains the major problem.

Thanks for reminding me about this topic.

Alas my colleague (a top bridge player) can turn on his Naim NAT and CD on his big Naim system, but the Naim App on the Muso is proving more difficult and a work in progress. I think Kurt’s excellent solution might make his eyes glaze over.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.