Muso qb 1 Touch Panel light seems to have died?

Only yesterday, touch panel on my QB gen 1 went off all of a sudden and has stayed off. Provided i guess correctly where to press – i can get the functionality and also via remote – and also via the naim app (so it connects to wifi OK) but the touch panel being off makes the unit hard to use. The base light is still working OK.

Anyone encountered this issue before and if so, how did you fix it??? i have written to Naim support – but i doubt the turnaround will be fast enough…

many thanks
enjoy/ken

I’ve not heard of this before. But did you try turning the power off and then restarting the Qb?

power cycle - one of the very first things i tried. to no avail.

I think the only other thing you can try would be to do a factory reset. But it does sound rather like a hardware fault.

You do a factory reset by turning it on and then pressing in the reset button on the back for 10 seconds (you need a straightened paper clip or something similar).

Are the QB firmware and Naim app up to date? Old versions included an option to disable the top controls which would, if enabled, result in the symptoms you are experiencing.

He says the top controls work still, if you can guess where they are, so it’s not just that cleaning mode has been selected inadvertently.

Give David’s suggestion of a factory reset a go.

factory reset in one of the very 1st things i tried. i am rather hoping it will just decide to wake up at some point. ah well…