Muso Qb failed Network Connection

Hello Naim Community.

I have a problem connecting my first gen Muso Qb to the network after upgrading to a Google Nest WiFi mesh router with a second point. I can see this issue has cropped up several times over the last few months. I have followed the advice, but to no avail. I am hoping that the posts that have petered out have some other options that worked!

My Muso has happily worked on my wifi with my NDX for a few years. I upgraded my virgin hub to a google mesh router plus point. The wifi works fantastically, everything connects as before, except the Muso. I have tried every combination of factory reset, rebooting the router (and modem), the muso etc. I’ve tried to connect via an ipad, a mac, an android phone and

Mostly I get an error message, via airplay, of ‘unexpected error’. But if i disconnect the second point, I can connect to the wifi. But the connection is lost when the muso ‘goes to sleep’. And I have to start again. I need the second point for my home wifi, so its not an option to have that permanently disabled. Of course, I can use bluetooth, but that means i can’t use it with my NDX as a home system.

The muso has v1.8 firmware.

Grateful for any help!

I’m not sure if it’s any help but I have three Google WiFi units (one primary connected to my ISP router and two secondary units) as well as a first gen Muso Qb that connects over WiFi. I do get the occasional dropout when streaming music to the Qb but it does always connect OK. The only thing that foxed me when I switched to Google WiFi was that it used a different IP address range (192.168.86.XXX) for connected devices compared to all of the other routers I’d previously used. Google have since updated their app and you can now re-configure the DHCP IP address range that Google WiFi uses but I’m just wondering whether you previously assigned a FIXED IP address to your Qb which isn’t on the 192.168.86.XXX subnet that Google WiFi uses out of the box?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.