Muso qb frozen during 2.0 update

This is still a problem as I just attempted to update the firmware from 1.8 to 2.0.

I understand a smartphone is complex, but I didn’t think it would be so complicated to update firmware on a dedicated audio device.

Power cycling, Ethernet connecting it to the Wi-Fi base station, and pressing the reset button for 6, 10 or more seconds will not move it out of the solid red indicator being on. It’s a brick now.

I sent an email to the tech support.

I hope that the support will help you soon. In the meantime you could try the tricks suggested in this thread (if you have not already).

Mine, 2nd generation, also froze during update. After testing everything, and after been checked by two service shops, I got a brand new one.

May certain settings initiate this ? Should we reset to factory setting before updating as normal for some other equipments ? The new one came directly from factory and updated without problems.

Still waiting for tech support to email me back - they are apparently quite busy now.

What’s your ticket number?

139069

1 Like

Thanks.

Please bear in mind that Naim are currently dealing with a backlog of email enquiries. They’re getting through them as best they can but there can be a bit of a wait before they’re able to respond properly, so your patience is appreciated.

Well, Naim tech support and I gave it several tries including redownloading the firmware update and writing it into the unit, but no dice. The solid red indicator persists, so I have offered to send the unit to them to troubleshoot if they are able to, else it’s going into the garbage bin.

Will just continue to use my Sonos units.

Farzad

I solved the same issue by doing the following:
1: Turn off the Muso (from the wall plug).
2: Press AND HOLD the reset button on the side - KEEP pressing while plugging the Muso back in.
(This will sidestep the Muso automatically going into the firmware upgrade cycle when simply turning back on).
3: Now release the reset button.

The Muso will then go into all sorts of gyrations but eventually will resolve.

1 Like

Glad it worked for you. It did not for me - mine is in the trash now.