MuSo Qb setup

I know do IT tecknical support BUT how the heck do I setup the wifi on my new MuSo Qb?

I have led flashing on the back (next to reset) and white ring around the big knob.

Tried the QSG and it says press the reset button for one second - well that doesn’t seem to do anything :frowning:

Okay… throw the QSG in the bin. Download proper manual and now I can see how to setup :slight_smile:

Okay user guide says default IP is… well that’s not right 'cause it’s allocated to my tablet!

So what is the default IP for the MuSo Qb?

Am I missing something here? I thought this was aimed at the masses end users!

Okay… try it with the app then.

Now it just sits there saying checking for firmware.

Note this is a tablet connected to the wifi from the MuSo. There is NO connection to the internet!!!

On the app, where do I setup the wifi?

I goto settings/other/network and there are no options to change the wifi :frowning:

Any minute it’s going to thrown in the skip!!!

Connect LAN cable to the MuSo.

Now I can get into it’s web address BUT I can’t setup the wifi.

How do I setup the wifi?


Okay… give in. Back in the box.

Hopefully NAIM support can answer the questions :frowning:

As far as I recall, the basic process is that during setup the Qb establishes a small WiFi network, you connect to that with your smartphone and follow the instructions. The Qb gets the WiFi credentials from your smartphone and when setup is finished, you connect your smart phone back to your normal WiFi network.

Done this… the setup this way says start your browser and connect to

That fails.

I don’t remember an IP address. I think the WiFi network was called something like Naim muso Qb setup. You let your smartphone connect to that and then maybe use your browser. But maybe someone who has done this more recently can elucidate.

Yep… this is what is says in the manual. Then it says connect your tablet to the MuSo wifi. Then start browser and connect to… fails.

Tried with firefox and chrome.

Interestingly the tablet says it’s IP address is which is REAL strange.

Tried via the lan port and you can’t setup the wifi if connected that way.

I’m confused… this is a mass market retail product… how can it be this hard?

You shouldn’t need any browser here. Just download the App to your phone or tablet. Open it up. Push in the reset pin on the Mu-So. and wait. Then follow the instruction steps on the App. Make sure you have good strong wifi reception - if in doubt do it close to the wifi router. Failing that, give support a call.

Okay… done it that way.

Reset button.

Use app to find the MuSo. It does this fine. Then sits there for 5 mins trying to find the latest f/w which, of course fails because it’s a private intranet.

Then goes to the main app screen showing the various music sources. No obvious way to change the wifi. Goto Settings and no way to change the wifi.

So you don’t have any internet access?

Not when the tablet is connected to the private wifi from the muso.

I did a reset of mine the other and just used the Naim app on Android. It’s a slow setup but it gets there in the end.

This is on wireless.

It’s been a stressful am and 2 hours on this hasn’t helped :frowning:

I’ll try again at home tonight. Reset to defaults and try the app route…
I’d prefer the web browser but, as a I say, the IP address isn’t as advertised in the guide :frowning:

Hi there. Just been through a painful process of reassociating my 1st gen muso with my wifi network so I do feel your pain. I am a little confused by some of your experiences though.
As Richard suggests you should attempt to add via the Naim app’ room setup process. The app should find your device which, in its wifi ready state (flashing purple light on mine) will be broadcasting its own network. Mine was some thing like “muso 4892”. The setup process adds the muso to YOUR existing network so once it is complete it will appear as a device on your home network and it’s original temporary network disappears. It should then have the same access to internet that any other of your devices does. I don’t understand your comments that the muso is connected but has no internet.
Have you somehow added your tablet to the temporary network rather than added the muso to your home network? Well done I guess. I have no idea how to do that.
If using an iOS device another approach is to go to settings/wifi in iOS and when you see the temporary muso network tap that and it will associate the speaker with your network.
Failing all that contact Naim support. They were very helpful with my issue although it took a while to get help as they are short staffed just now.
Good luck. I find the setup process for the muso devices infuriating and opaque.

Don’t forget that a full reset means pressing the paperclip button and holding for 6 seconds, then release.
Hopefully it’ll work flawlessly at home - it’s a long time ago that I set up mine but recall it simply worked for me (sorry!)

1 Like

It looks like you aren’t waiting long enough for the muso’s inbuilt wifi to activate and become visible to your laptop.

Disconnect your laptop from your standard wifi. Select to connect to another network. Wait for a name along the lines of muso-xxxxx to appear. This may take several minutes - keep refreshing the available networks list. Connect to it.

When you’re connected I can’t remember if you have to start a browser and go to, or whether a window opens to ask for your wifi name. As soon as you put in the wifi name and password the muso will drop connection to your laptop and join your wifi network. Reconnect the laptop to your network if it doesn’t do it automatically.

If that doesn’t do it, swear profusely.

1 Like