Muso QB won’t work with mesh Wi-Fi help!

I’ve had my QB (version 1) for a few years now and it was always running great o a simple BT home hub 1 router set up. We’ve just moved into a larger house and due to the lack of fiber broadband we’ve gone for a EE 4G router connected to a TP link Deco Mesh system. Speeds are great and everything else runs perfectly on the network, except the Muso…

Does anyone have any tips for router settings etc to get it to work? I’ve tried switching 5hz off, connecting via Ethernet and using the mesh system in access point mode rather than router mode. The radio stations, Spotify connect and all network features simply wont play ball. One in a 100 times it works and then drops out and stops.

Hi, the 1st gen Musos had prehistoric 802.11g WiFi modules fitted which are not great. There’s a better chance of them working reliably with a better router, and BT Hubs are better than most. Ideally you should stick to wired Ethernet to get around this problem.

When using any additional network devices such as additional wireless access points, range extenders etc its important to ensure that only one of them is acting as DHCP server. Normally this would be your main router, in which case the DHCP on other devices should be disabled. You should also try turning off WiFi on your router so that the Mesh WiFi is the only wireless network running.

2 Likes

I have a Muso Gen 1 and had to get a Ubiquiti range extender to get it working reliably via wifi. Chris is right about the dreadful wifi modules - of all devices you own, it will almost certainly be the one with the crappiest wifi. Everything else may work but that means nothing! They are great when they do work though.

I’ll give the DHCP thing ago. It’s in the same room as one of the mesh extenders and it had the same issues when connected via Ethernet unfortunately. Presumably if all else fails I could connect it to a dedicated music streaming/ airport box via the optical port and just use it that way.

I would suggest that you make sure your network is set up properly first. It would be a shame to have to bypass the Muso streamer by using a third party device into the optical input, and there’s no guarantee that it wouldn’t be equally susceptible to whatever network setup problems you may have.

The first thing I would do is check that only one DHCP server is running, either on your router or on one of your mesh devices, but not both.
If you make any changes to network settings, always restart everything before you use it again.

2 Likes

Both great tips. It’s easy to end up with 2 wifi networks, one from the EE router and one from the mesh devices. And easy to have the QB trying to connect to the “wrong” one.

The EE is your home router, so yes putting the mesh devices in ‘access point’ mode makes sense. But EVERYTHING has to connect to it. If some things connect to the EE’s wifi and others to the mesh devices, those things cannot communicate with each other.

Do you hardwire anything with ethernet cable? If so, hardwire it to the mesh base, NOT the EE. The only thing that should be plugged into the EE router is your mesh base.

So, I just want to update the thread, as future people having the same issue may end up here looking for a solution.

The tips given were all spot on, pointing out that the network is usually the source of the problem, not the QB. I tried to get my printer up and running on the network yesterday and suffered the same issues so figured it couldn’t hurt to try a different router.

I swapped the EE piece of junk for a new TP-link 4g model and instantly all the problems went away. It works in both mesh or access point mode now and connects instantly first time every time. Problem solved!

3 Likes

Good to hear that you have a solution! Your EE router may be a piece of junk, but I think the issue was more than likely that it just wasn’t (and possibly couldn’t be) set up to work properly with your TP Link mesh gear. That shortcoming could be in the router, or the mesh devices, or maybe you just never had it set up correctly. Either way, sticking to a single brand for all your network hardware is usually a safe bet.

Just wanted to say thank you to the people on this thread. I installed mesh Wi-Fi a little while ago which solved all our Wi-Fi problems but had the impact that the QB would not play my network music (but would do radio and streaming fine). Following this thread I have switched it to Access Point mode and it is now working perfectly. I am very happy with this.

@ChrisSU Yes you’re probably right. I think the issue was likely with the DHCP settings, but unfortunately the mesh system I installed doesn’t have any DHCP options (apparently a great source of complaint) and the EE router has very little in the way of settings as well. TP link mesh seems to play nicely with TP link router which is at least something. Very nice to have QB up and running anyway!

I had a similar thing with setting up a tp link mesh set up.
It took little time to set up better wifi all over the house but knocked out Sonos entirely.
With a lot of help from Sonos support I set them all up again. The mesh was set up to access point mode using the settings on the app. A sonos boost was plugged into one of the discs and all 5 setup one by one.
I don’t know if that helps but I did get there in the end.

1 Like