Muso qb1 not a great decision with hindsight

I have a MyCloud, an older one which came with Twonky installed. Is that what you have? My MuSo 2 works fine with it (as do my Nova and my ND5 XS 2).

My Muso v1 just works. It plays music from the NAS, Qobuz, internet radio, and BBC Sounds via Bluetooth on the iPad.

Sounds like with your network isn’t working or maybe a firmware update hasn’t stuck. Have you tried a full reboot of your network and the QB? That’d be a worthwhile start point. Bottom line is this stuff does work, unless something has gone awry.


This doesn’t sound right. Plugging in a USB of music files should not result in the unit going into “meltdown”. Is everything to date with the Mu-So Fw and the App? Have you been in contact with your dealer or with Naim support?

I have 3 x Muso QB 1’s and they all work well.
Very, very occasionally, usually after a power cut, I have to re-boot the system and reconnect the QB’s which are all on wi-fi, but generally they just work.
I’ve never had any real issues with the app either, always using a very old iPad and or my iPhone 11.
There seems to be something “odd” happening in your setup.

It just won’t find the qb on the iPad app, says no rooms found.

I’ve tried deleting and reinstalling the app, reset the qb from scratch. It works fine with the android app, finds it immediately. It is probably a fault with my network but there are lots of other things like sky q, printer and other devices on it and all working fine. I do wonder if it’s to do with the dual band 5G on the router.

Tidal is absolutely fine. I don’t really listen to radio but that works. It’s the NAS that I struggle with, also I thought just plugging a usb stick would be fool proof. Maybe I need to try it with a few different brands.

I’m going to try again with a new usb stick and try one file/format at a time. Would you recommend a particular brand? I’ve looked on forums and other info but I’m not a WiFi expert and I can’t be doing with the stress. I don’t want to mess about with the WiFi too much in case sky q gets messed up and my wife will be very cross. Bluetooth is actually working fine now from my phone , I tried to use the Bluetooth on my Astell and kern jnr player so I guess it was the player that was at fault not the qb.

1 Like

The USB stick has to be in the correct format otherwise the QB won’t read it. I was copying some music onto a new USB stick for my brother recently and was baffled as to why the QB wouldn’t play it - I wanted to check because I knew he would be playing it on a mk1 Muso. I then discovered the problem via Google - wiped the stick, reformatted it, added the music again and lo and behold - sweet sounds. I may be misremembering but I think I had formatted in Fatx and it should be Fat 32, but please don’t take my word for it.

I have in the past had problems with my QB dropping out when playing the radio via wifi and then not being able to reconnect on the app. I have Apple devices and there are some strange ways in which they interconnect and now I have disconnected the Apple Express, which I was using as an extender, it works fine with just the occasional glitch - I think perhaps it’s that the BT connection to the internet sometimes goes awry.

The nas works fine on the Sonos, it’s the qb I have problems with. The android app seems to have quite limited functionality but when the iPad app still worked for me the qb was better at handling the nas files. If I go onto the mycloud iPad app I can find the files,and even play music files from the mycloud app on my ipad.

I love my Qb V1.

…I had my QB 1 for a couple of weeks, it just did meet my expectations and moved it on.

Very possible. This post might help?

(and the whole thread if you haven’t read it)

Or this one:

I am reading this with interest as I hope someone on here can help me with a similar issue. I have a Uniti Star and a WD mydrive live (at least 10 years old) using twonky media. My old Sonos units play music from this perfectly but my Star can see the drive but no music on it. I can’t work out what I need to do to make this work as I am sure it can. All the music on it is saved as ALAC files as I have a Mac and used to use an iPod. I don’t really want to have to use the Mac to control anything as I rarely turn it on these days just use an iPad or iPhone. It is not a problem if it doesn’t work because everything I want to listen to is available on Qobuz or Spotify but it would be nice to have it working. Any suggestions gratefully received.

Thanks I will give that a try.

I guess that might be the issue but I’m afraid that’s too complicated for me, I just want to listen to music. Like I said at the start, Sonos just works.

Did you contact Naim support, they should be able to help with whatever the problem is:
T: +44 (0) 1722 443405
Hours of service are Mon-Fri 9:30am-5:30pm GMT/BST

Bizarrely I just tried switching my iPad between 2.4g and 5G a few times, but no change. So I had one more go at deleting and reinstalling the app, and its now working on the iPad. I’ve tried deleting and reinstalling regularly over many months but no to no avail, but swapping to 5G and back seems to have done it.
Maybe all the helpful suggestions gave me the positive drive to sort it out. Thanks all.


Sometimes it’s just weird! :man_shrugging: Glad it seems to be working, good luck!

1 Like

Seconding @Suedkiez (from the US), I had that problem with my MuSo 2. I was able to set it up by connecting it through Ethernet. After I removed the cable, the app still found it.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.