Muso remote

Ok guys: HELP!
I’m bu##ered if I can get the cover off to remove the ‘battery isolator’ :face_with_symbols_over_mouth::rage:

Any (Helpful) advice gratefully received :relaxed:

If this does not work (yours seems different?) try the various answers here:

Many thanks for your prompt response.

Mine has not got the ‘upside down Naim curve’ on the back. I thought I’d take a closer pic, & one of the front of the remote so that anyone else with the same one could help :relaxed:

Yeah I figured. Is this from an original Mu-So, not the second edition? Sadly I have no Mu-So at all around me. From the picture, my assumption would be to press down at the three dots and then slide downward. But who knows how idiosyncratic that one may be. Best to wait for a Mu-So 1 owner then …

1 Like

I think that looks like the version that you ‘push down in the slot and slide’ - but it looks like that’s what you’ve tried to do!


I have a Muso. Push down with a pointed object (knife) in the slot and slide down on the 3 dots.
Two hands required, very poor design


Hi dknk
As you can see from my 1st pics; tried that (see small screwdrivers that I put in the slot) & I cannot get the thing to slide off :grimacing::blush::rage::joy:

It can be done! But could be tricky if you damage it I guess.


Bless you: I’ll perceiver - if I manage it I’ll post a pic :+1::blush:

:notes:The sun has got his hat on, hip hip hip hooray :notes:

:joy::smiley::rofl: Done it!!!

Many thanks for your help chaps :+1:

1 Like

Well done ! Indeed dreadful design which has foxed many on this forum…


Brute force wouldn’t move it.

Had to use a knife and thankfully didn’t damage the plastic body.

Not looking forward to next time….

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.