Muso v1 blinking purple and will not connect

Hello, no changes to my network, Muso started flashing purple and will not connect to my router now. I’ve powered down all devices, network, muso, multiple times to no avail. Did a factory reset on the Muso, nothing. The Muso attempts to connect to my network but always ends in the “An unexpected error has occurred. Please try again.”

Also, in the setup menu the Muso shows it’s connected to my network and has the check mark next to it.

My wifi/router is a Ubiquiti Amplifi HD, no issues that I can see. I can see all my devices except the Muso.

Can the wifi on these Musos go bad?

I was able to get the muso to work on my gf’s network so the muso seems good to go to me. Returning to my network it falls into the same error message "An unexpected error has occurred. Please try again.”

Looking at the list of devices on my router (Amplifi HD) I don’t see the Muso listed. Not sure what else to do but try a factory reset of my router.

You could try using an Ethernet cable rather than relying on WiFi. That may not be convenient but you could try it and see whether it works.



There should be error logs in the ubiquiti router control panel that may show what is happening.

1 Like

Well after resetting the router it still errors out with the same error message. Thanks @robert_h I will see if I can find the error log and see what that says.

The Muso still works when wired into my network but I’d like to understand why the wifi with the Amplifi router stopped working.

I’m not finding an error log in the control app. The muso is in the BR and I have both mesh points int he BR as well. While the distance from the router is not too significant it does have to travel a hard angle and narrow passage to the BR. The mesh points are currently set for 5ghz so I wonder if switching the mesh points to 2.4 ghz might make it easier for the muso to connect. Such a weird issue since it’s worked fine for months and I can’t think of anything that is different. There was an update recently but it’s been working fine until now.

Well after resetting router and mesh points I get the same error message. It looks like the Aplifi router just doesn’t like the Muso anymore. So weird. Maybe the new app update will make a difference.

After a couple resets of the router and placing the muso to the same room as the network I got it to log in. For some reason it was hanging up at the last part where it says “waiting on Muso”. Moving it to the other room got it over the hump. I’ve returned the Muso to the BR and it is streaming wifi fine again. Kinda weird since it had no issues logging on to the router from the BR when I first set it up. It buffers occasionally but not frequently.

Wrt the mesh points in the BR, is it better to have the antennas set to 2.4 or 5 ghz? I figure since the Muso is 2.4 I should have them at 2.4 but not sure.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.