My NDX2 - I seem to have killed its output

My system comprises an NDX2, SN3 plus HiCap, CD5Si and the other day I added a CD555PS:
To install the new 555 power supply I turned everything off, connected the 555 to the NDX2 with a Burndy cable and then stupidly turned everything on again without first checking that I had disconnected the original NDX2 power cable. The NDX2 was then powered by two power sources: direct mains along the original cable and a second power supply from the 555 via the Burndy cable. I quickly turned everything off and since then the NDX2 has looked like it’s working fine, but no sound comes from my amp. It’s as if the NDX2’s output circuits have been burnt out (which may be what has happened). My dealer (who didn’t supply the 555 but who has kindly offered advice) has advised me to check the din cable (untouched), take the NDX2 back to factory-out-the-box new (done), check the NDX2 output is set to “din” (done) and all to no avail. The NDX2 now looks like it’s working fine - everything appear to work, but no sound comes from my system. (My CD player still produces sound thru the amp, so the amp is working.) I have phoned Naim Support and I’m sure they’ll call me back next week. (It’s Friday night now.) I am told that the NDX2 has an internal system that detects this exact two-power-supplies user error (easily done) and deals with it. However, I am concerned that somehow I have got past the failsafe and toasted my NDX2. Any ideas anyone? Can I connect my NDX2 din cable quite safely to the SN3’s CD input, to check whether the SN3’s streamer input has been roasted? Help please… Thanks.

Doing this could not possibly have damaged the SN3. It’s highly unlikely that the NDX has been damaged but if it’s showing as playing in the app, and the output is switched to din it should just work.

Have you gone back to square one without the 555 to see if it works? If so, remember to reinsert the black blanking plug back in to the burndy socket


Sure, why not? Just take care of the correct switch-off (first SN3, then NDX2) and switch-on (first NDX2, then SN3) sequence. By the way, have you double checked that the NDX2 output and the SN3 input are the correct ones? It seems to me very unlikely that you have made any damage to the system …

As Nigel has posted above, I doubt this would have damaged the amp, so any issue should just be confined to the streamer.

Try going back to just the NDX2. Remember the link plug… anything? Then Try switching to the RCA phono output? Do you get any output?

1 Like

I’m also sure you won’t have done any harm. Naim know this happens sometimes and all of these devices are protected from Naim owner’s over-enthusiasm with power supplies.




Yes, I have done that, with the blanking plug in, and with the NDX2 getting power from its original “kettle lead” mains cable…all to no avail - the lights are on, and it seems to be working, but no sound :frowning:

So. If I’ve read this correctly, you have powered the ndx2 and 555 whilst connected by burndy?
Check the fuse in the 555.
And of course remove the power lead to the ndx2. And refit the burndy.

Have you checked the output is still set to DIN, and hasn’t reset to RCA?

1 Like

No it’s not that. He’s powering off its own power unit now.

Yes that’s what I think might be the issue.

Has he refitted the burndy plug properly in the ndx2?
The fuse in the 555 will have blown.

If everything is powered up, shows as playing then it is likely to be an input setting issue.

If the fuse had blown the unit wouldn’t be operating, which is is, just with no output. Checking the din output is enabled is the thing to do. Check also it’s set to fixed output.

I have now tried that…the NDX2 did not produce sound when connected to the SN3’s CD input… :frowning:

I have checked that the output was set to DIN when I used the DIN cable, and I just swapped in some RCA cables, and changed the output to RCA. Sadly that setup didn’t work either

I just tried RCA cables, and switched the output mode to RCA - sadly didn’t work :frowning:

That is what I have expected and suggests that the NDX2 output is not set to DIN, I would say.

It really shouldn’t have done. And anyway he is not using the 555 now.

It’s sounding like a coincidental relay failure in the NDX2 now. Back to the dealer…