N-serve connection to HDX


Can someone please help! I am unable to connect to my HDX using the n-serve app. I have tried my iPhone, iPad and MacBook and none of them are finding the device. With the iPhone it displays the library of music on the HDX but I can’t connect to it and play.

It’s driving me mental! Any help would be greatly appreciated.


Turn off your HDX and the router. Wait a couple of minutes. Turn on the router and let it fully start up. Turn on the HDX. Hopefully that will sort it out.


Thanks but that’s not working either. I’ve added a couple of screen shots from my phone. When I click connect when on the artists page, it doesn’t whether auto connect is selected or I type in the IP address

Hopefully these help?


Have you tried swiping the app off the screen and restarting? If that fails have you tried deleting and reinstalling it?

Are you connected via wifi or Ethernet cable to your router ?

Ethernet is by far the best & least problematic.

Yes tried that thanks

I’m connected via ethernet

What’s odd is it says no servers found. Maybe the HDX is offline. Can you check using the desktop client or via the web interface?

Hi Dan. I’m an HDX user myself.

Is yours an SSD model (accessing files off a remote NAS server) or is it the stand alone model with a built in hard drive?

If the former are you able to play music by using the touch screen on the front panel - if so then the HDX is certainly picking up the files from the network. If not it could be a faulty network component or a loose or faulty Ethernet cable.

If the later, again can you play some music from the front panel? If you can’t that might suggest a fault with the unit itself.

You can use the front panel to see the IP address: select Home>System>System Status you should see the IP address of the HDX displayed.

Is everything else on your network working OK? Has anything been added or amended recently?

I’m not a network expert I’m afraid but hope the above can help you resolve the problem.




I’ve checked the desktop client and it’s blank - no data at all is displayed.

I have the stand alone HDX model - one of the early ones released. I can access & play music from the front panel. Everything else is working ok

Maybe I need to take the HDX in for a check-up?

Thanks for your help

It sounds like it’s not connecting to the network, but I’m no expert. Are the little lights by the ethernet socket flickering? Maybe you could try a different cable.

Hi Dan.

What happens when you rip a disc. Does it retrieve the metadata and album artwork?

What happens if you try and play an internet radio station?

If it is doing this OK then it must be connecting to the network.



Hi John

Internet radio works fine, but when I have ripped discs of late the Meta data & artwork hadn’t been retrieved. Artist name & other data has been wrong a few times lately.


Is the firmware up to date? The latest is 1.7c but its existence was not widely publicised by Naim, and it addressed metadata retrieval issues.

Well if the radio is working OK it’s definitely connected to the network.

I would establish what version of the firmware the HDX is running and then contact Naim support. As the firmware has been updated over time so have the app and desktop client - it may be you are using a version of those designed for a later version of firmware than you have installed on the HDX.




It’s a long shot, but did you try and delete your current Naim n-Serve App and download a fresh one ?

If You can select and play music via the front panel, then the HDX and your NAS are on the same network for sure - but if Your phone and Your desktop client cannot see the HDX, then it sound like they are connected to another wi-fi network, maybe the run on the 5 Ghz connection.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.