NAC 52 balance control not working from remote

Not a big issue for me I as I never use it; but I’ve noticed it has stopped working. Tried two different remotes to check that is not the issue. Has anybody else had this issue before, and if so, how did you go about fixing it? I don’t intend to send to Naim and lose the unit for weeks on end! Thanks.

Send it to Darran at Class A in Sheffield. You can either drop it off and collect or arrange a courier. He’s turned stuff around in a week in the past and some things he does while you wait. Send him an email.

Thanks, I will call him. However, I note on his site that he can not supply any internal Naim parts.

I think that means supplying parts only. He sources all parts from Naim.

Ah, that makes sense, thanks

I had the problem with the volume control on an 82 and it was the volume control knob that was seated to far in towards the facia of the pre amp. Solution was to pull it out just a little bit. Might be the same with your 52 and balance control knob.


Wow, many thanks, that did the trick. So simple, but 100% effective!


I’m glad it worked. :blush:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.