Naim app and Asset peculiarity

I have the Naim app on both Apple and Android devices.
I also have the Asset server working on a Raspberry Pi and on a Pi Zero.
Everything has been working flawlessly for a number of years.
But now, for whatever reason, the app (both Apple and Android) does not pick-up the full Asset browse tree from the Raspberry Pi whereas it does from the Pi Zero.
To further confuse things my Naimuniti does pick-up the full Asset browse tree from the Raspberry Pi when accessed through the device’s internal screen.
Am I missing something?!
Any suggestions gratefully received.

Worth trying a restart of your phone or pad. There’s certainly been a few experiencing this recently on iPads (me included).

Thanks for the suggestion Gavin. I’ve tried that along with a few other things but no change.
However, as a completely random approach, I have just deselected Asset A-Z listing under composer, restarted Asset, reselected A-Z listing under composer, restarted Asset and hey presto we are back to how things were. Not sure I understand the logic behind this, let’s just say a gremlin.

Gremlins (one or more!) definitely at work here. The A-Z listing comes and goes. Where the instability lies is anyone’s guess.

It’s worth reporting your experience and observations to Naim support via email.

I’m also copying in @tomvamos so he’s aware

My conclusion - based on your reports - is that something has changed with the Raspberry Pi…

Thanks for all your responses.
Well, yes and no to @IanRobertM suggestion.
The no is that I am also running a Minimserver, Logitech Media Server, Twonky and JRiver server on the same Raspberry Pi without any problems.
I suppose the yes is that either there is a malign interaction between these servers and the Asset server (but previously there was no evidence of this), or that, as you suggest, the Raspberry Pi operating system has been updated and broken something.
The PiZeroW only has the Asset server (same version) and the Logitech Media Server (again, same version) running and there are no issues. Admittedly the PiZeroW has fewer servers running and it is a more recent version of Linux.
BTW, this doesn’t cause me sleepless nights but to me (geek!) is a vaguely interesting issue.

Something has changed, as a result.

It is likely to be very difficult to find or fix this. All you can do (IMO) is update ‘everything’ - and try again.

At first glance (and it looks like you may have already reached this conclusion) it sounds like Asset is struggling to co-exist with the other services on the RPi. Have you tried it in isolation i.e. disabling everything except Asset and, if that works, bringing up the services one by one?

I suggest your search or post/ask the question on Assets forum,
They are very good & normally have answers pretty quick.

Many thanks for the helpful suggestions. I will try them all and see what happens.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.