Naim app can see NAS but stopped playing files


I recently bought a ASUSTOR 2 bay NAS to revive all of my old mp3’s that have been dormant for around a decade.

I have a ND5 XS2 connected via hard wired to an English electric switch, the NAS is also connected to the English electric switch which in turn is plugged by wire into TP Link X55 Deco mesh network.

Yesterday, I transferred all of the files (and was shocked at the increase in transfer speeds from 10 years ago!), and set up media server UPnN on the NAS, pointed the server to the correct files, fired up the naim app, clicked server and it found it and I was playing files in no time.

Today, however I tried to play some other files, and indeed the same files that I played yesterday and it doesn’t work, just sits there a 00:00. I tried the same files natively on the NAS and they work. It can see all the files but it will not play them. file types are mp3.

The NAS, ND5, in fact all of my devices have static IPs.

Any help, greatly appreciated.


Do you have a PC or Mac that you can install VLC player, then from that there is a upnp option on the left which should see your NAS drive. From here you should be able to stream music to your PC. This would help confirm if issue is NAS or Naim box


Downloaded VLC and can see the NAS drive and tested a number of songs and no issues playing.


In that case physically unplug your ndx xs2 from the wall for 5 minutes

No dice mate. Same issue. I thought it might be the media server so I’ve downloaded emby but thud doesn’t show in the list when I click on server as the source.

What is weird is when I first clicked server, it only showed me an option for local. This is what led me download and setup media server v2 upnp on the nas, which then showed as a second option under local automatically.

As the nd5 has no native storage what is the local option meant to access?

You can insert a usb drive into the back with all your music on it, then it all shows up under local including artwork and artist detail. I use that method in addition to my NAS as a sort of backup . It works extremely well

Also worth checking that your Nd5 network cable is secure. If you have a spare to try, even better

I advise to delete all the static IP’s & go to DHCP, its a lot simpler & it can fix this & other issues.

Oh I figured that was what the usb input was for.


I’m not sure this will work for me though, if the up is always changing then I need to keep remapping the drive in windows etc.

Been a while since I did any networking stuff but static was always the way to go but maybe things have moved on

I used to fix IPs but no need on the nd5 . Presumably you aren’t mapping a drive to it, so suggest follow mikes advice

Also check nd5 network cable

I can delete the ND5 static no problem. As you said, no mapped drive there so isn’t an issue.

Will try and update later.

DHCP is designed specifically for simple single network home applications, not forgetting a DHCP address once allocated is effectively static with most routers.
A static IP address allocation does just the same but has the added potential of human error.

It’s possible an IP address has been muddled up in the DHCP licence IP table, or it’s been associated (a bad link) with an IP address that is already in use by another device.

Just to confirm, presumably it’s your router that has dhcp enabled and then disabled on your mesh?


No i have a virgin router acting in modem only mode. The mesh does she DHCP.


Still not working after removing the static IP on the XS2. I am no networking expert but if it can see the server, but isn’t playing the files doesn’t logic point to another issue? I consider it was the formats maybe but the files played before so it can’t be that?

Change the IP address on your control point (the device with the Naim app).
It’s this device that sends your instructions to the ND5 & receives and displays album art &;info during replay.

This seemed to work! Thank you so much.

Though very curious as to why…ip is an ip i thought, shows my networking skills!

And the best thing of all is I can listen to Dave Matthews Band (most importantly live at luther college) again! as they are not on any streaming service.

Thanks again!


Ok, it was going good but next day and today I cannot see the server :frowning: anymore.

I have checked on the NAS and the server is running.