Naim app can't reconnect to N272

The Naim app on my Android phone regularly fails to reconnect to my N272 streamer after the phone has left my home network (which is most days). Only fix I’ve found so far is to factory reset the N272, which gets a bit tedious after a dozen resets.

Issue may be specific to my network (most streaming is via Tidal / Audirvana UPnP) but just wondering if anyone else has experienced similar / found a solution. Latest versions of app / firmware in use. TIA

You should almost never need to factory reset the 272. A power off restart is usually sufficient to sort anything out.

And anyway you can be sure your 272 doesn’t forget your network just because your phone has gone somewhere else. You could try closing and restarting the Naim app on your phone. That should make it look harder for your streamers.



Is your phone remaining on a cellular connection when you return home? Mine often does, at least for a while, and will then eventually switch to my home WiFi when I happen to move to part of the house with a weak 3G/4G signal.

1 Like

Have you tried deleting the app and reinstalling.

Sometimes I’ve done that and connection gets reinstated

Stopping the app and restarting it should be enough. But I do mean stopping it and not just deselecting the app. On an iPhone you swipe it off, but I’m not sure what the Android equivalent.

Deleting and reinstalling the app only has the advantage that you delete all the information that the app retains. It really shouldn’t be necessary to do this in the case of talking to a 272 which is a very stable product.



Thanks for replies. I’ve tried all the above advice, but none have sorted the problem.

Suspect switching between the Naim & Audirvana apps via multiple devices could be partly causing the issue (given the latter is already a bit glitchy).

Not a huge problem anyway. Easy enough to select radio stations from the Naim remote.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.