Naim app defaults to setup screen

Hi all. Am new to Naim… just bought the Mu-so 2, managed to install the speakers on my iPhone app. However , I am unable to see the device options screen within the app for more than a millisecond.

As you can see from the screenshots, the speaker is setup and shows in ROOMS. When I click on the device, I am supposed to see the second page which shows radio/qobuz/tidal options. However that page barely shows up for a millisecond before it goes back to the setup new device page.

Tried deleting and reinstalling the app, still the same error :man_shrugging:

Am I getting some basic setup wrong?

In case you are wondering, did a screen recording and then paused at exact time to take that screenshot :grinning: speakers sound amazing though!

How is your muso connected to your network? I’m guessing via WiFi, though via Ethernet should be more stable. Is your phone on the same WiFi network?

Yes connected through wifi, iphone and mu-so on the same WiFi network. I can imagine connection will be more stable through ethernet but the app behaviour shudnt be affected by that?

Have you rebooted the Mu-so?

Yes, had rebooted both the app and the mu-so

Have you tried resetting via the pinhole button?

The same happened to me when I set up my new Muso QB2 last week and it took me ages to work it out. Just continue with the setup process. It will ask you what colour is the status light. Check it (it will be different to what it was when you were originally setting it up) and click on the right button and follow the instructions.

Sorry for the late response, busy holiday season!

Thanks for the tip … just went through the process again as you suggested and worked beautifully thereafter. Such a simple thing, looks like a bug deemed non-critical for them to bother fixing :rofl:

Have a great year ahead everyone :pray: