Naim App doesn't find music files on Windows 10 laptop

Hi kind folks

I have an ND5XS2 with wired connection to Asus router, and ethernet connection to Lenovo laptop running Windows 10. Naim app installed on Samsung S8. Ethernet connection to second router acting as an access point.

From the app, the file path to music files on the laptop works most of but not all the way - I can get as far as:

Servers>UPnP servers>[my laptop]>Music>Folders>[my music] - which then correctly lists all the subfolders I have set up in Explorer e.g. band and album names.

Beyond that however none of the actual music files (mp3, m4a, flac, wav) are displayed - just ‘No Results’.

If I add a new folder in Explorer at this level it immediately shows up in the Naim app - so there is definitely a real time connection there.

At the level of Servers>UPnP servers>[my laptop]>Music, the folders there (Album Artists, Albums, All Artists, All Music, Composers etc) are also all empty.

I’ve tried a whole bunch of things to try to fix it including:

  • Turning off AV (Bitdefender) Firewall (and setting up firewall rules to permit access to the specific IP addresses for the ND5XS2 and Samsung S8, sourced from the router’s admin centre)
  • Adding Bubble UPnP to both the laptop and S8. Possibly revealingly, from the S8, using Bubble to follow the same file path as above also displays ‘This Folder is empty’ at the final folder level where the music files are.
  • Rebooting laptop, phone, and router
  • Updating router firmware
  • In the Naim app, Rebuild Music Database and Reset App
  • Disconnecting the ethernet connection from main router to access point router
  • Streaming/casting to the ND5XS2 from Windows Media Player (which accesses the same [my music] folder on the laptop as the path above) - works most of the time (only for mp3 and m4a files though).

To add to my frustration, I previously had it working fine earlier this year. Only changes I can recall making to the network and OS are the usual automatic Windows Updates, AV updates, and switching from ADSL to fibre broadband (and associated changes to main router setup). Argh!

All ideas most welcome, thank you :slight_smile:

I know someone who spent a long time getting very frustrated with trying to use a Dell Windows-10 laptop as a server. I did not get involved other than suspect the Windows UPnP server is not up to the job, I also advised him to get a pukka NAS server, which he said was not required ( OK … bi-bi )
He eventually found & installed both Minimserver & Asset UPnP for Windows a few months ago, not sure what he ended up choosing, but both fixed his problem.

Brilliant, thank you both, that’s worked a treat. It even shows up in the desktop Nox Player so I can now control the ND5’s access to my library from there too. Marvellous :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.