Naim App iPhone X Dropout Naim NDX

I’ve been trawling through all the other posts on this so can see it’s a common issue but I’ve not managed to resolve it.

The problem is the Naim app keeps on losing contact with the media server if I restart everything it can hold it for roughly 10-15 mins. But if I go to a different app or close the screen and come back it’s forgotten the media server. So if I restart the media server on the computer most of the time it comes back, a bit of a faff. Interestingly the NDX holds onto the server solid and I can browse songs on the front buttons but that is obviously difficult to navigate.

Also one small thing that maybe related when I click the ‘stay connected’ button in other settings in the app it clicks all fine. But when I check it half an hour later it’s unticked itself!

I’ll try and give as much info as I can to what I am using:

iPhone X IOS 14.3
Naim NDX wired via powerline adapter
iMac OS Big Sur wired via powerline adapter
Plex media server
Plusnet hub one router

I can see some of you are very knowledgeable on these sorts of issues so any help would be most appreciated as I do love the sound of the NDX!

The first thing I’d do is to throw the powerline stuff in the bin, in line with the WEEE directive of course. Then run wired ethernet. That should sort it.

Wired ethernet would be the dream, but it’s just not feasible in the old Victorian house we are in. I have visions of all floorboards being lifted up and walls having channels routed out of them! :house_with_garden:

In that case get a decent Mesh WiFi setup. Either use WiFi on the streamer, or wire it to one of the Mesh satellite devices.

Ok thanks :white_check_mark: so would the mesh be a better connection than using the wired powerline adapters ? Only ask as the TV in the neighbouring room is also on a powerline adapter and can handle 4K over it very reliably. Don’t want to rock the boat too much with that.

Any particular mesh systems you would recommend ?

Another thing you can try, as Ethernet cables are so cheap, is try connecting with an Ethernet cable just laid across the floor etc and see whether that solves your problem. You don’t need anything fancy. Cat 5e is fine, bought from any number of suppliers on eBay, and you can go up to 100m if need be (although they get more expensive that long just because of the length!)

I had no end of trouble with my ND5 XS2 being lost from the Naim app all the time powerline extenders were present on the network. The streamer was connected to Wi-Fi in the same room as the router, not wired to the extender but the very presence of them on my network was enough to cause problems. I switched to a BT Whole Home Wi-Fi mesh system and the problems went away. Assuming you’re in the UK the BT system is hard to beat. It will work with any router and any ISP so you don’t have to be a BT customer.

I’m getting the same problems with the NDS and Naim app.

It’s all hardwired through Cisco 2960 switch. The NAS drive visibility of files keeps dropping out on the App.

Everything is there on the NDS list on UPnP, just drops out on the app.

Seems like lots of people are having the problem on the legacy streamers.

Any chance Naim can look into this?

Many thanks. Used to be okay with older versions of the app. Now worse than ever!

Ok thanks will look into it. :slightly_smiling_face:

Did you try restarting your router? You will need to restart the NDS too.

I use the Naim app on an iPhone 12 Pro with three legacy streamers, one new platform streamer, a Qb version 1 and a UnitiCore and everything is always instantly available. There is no problem of the new versions of the app not working with legacy streamers.



Thanks David.

It’s the Android app. Have reset the NDS and router. Have tried a different phone and still no joy!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.